summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Buch2022-11-08 15:01:23 -0500
committerDan Buch2022-11-08 15:01:23 -0500
commitd02df23ceb55a818f3a83c24bceba853217d30aa (patch)
treeeee8f00b6a7ec8dcac34bac3f68564bded420874
parent17ed0ac58c44f4dccbd48394b53106a9c62d8ab8 (diff)
downloadaur-d02df23ceb55a818f3a83c24bceba853217d30aa.tar.gz
Point to new home + use git for version
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD11
3 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee1471a22f25..3705719cdc51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = gimme-git
pkgdesc = gimme is a shell script that knows how to install go. Fancy!
- pkgver = r211.1752cb8
+ pkgver = v1.7.1
pkgrel = 1
- url = https://github.com/travis-ci/gimme
+ url = https://github.com/urfave/gimme
arch = any
license = MIT
makedepends = git
- source = gimme-git::git+https://github.com/travis-ci/gimme.git
- md5sums = SKIP
+ source = gimme-git::git+https://github.com/urfave/gimme.git
+ sha256sums = SKIP
pkgname = gimme-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..949a523c4cf6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/gimme-git/
+/pkg/
+/src/
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index 965bb7b5af72..de0d58e8a8e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Tristan Rice <rice@fn.lc>
+# Maintainer: Dan Buch <dan@meatballhat.com>
pkgname=gimme-git
-pkgver=r211.1752cb8
+pkgver=v1.7.1
pkgrel=1
pkgdesc="gimme is a shell script that knows how to install go. Fancy!"
arch=('any')
-url="https://github.com/travis-ci/gimme"
+url="https://github.com/urfave/gimme"
license=('MIT')
depends=()
makedepends=('git')
backup=()
-source=("$pkgname"::'git+https://github.com/travis-ci/gimme.git')
-md5sums=('SKIP')
+source=("$pkgname"::'git+https://github.com/urfave/gimme.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --always --dirty --tags
}
package() {