summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordemostanis2022-07-21 12:00:20 +0200
committerdemostanis2022-07-21 12:00:20 +0200
commit46d73a85c241b5e19521af689024ab25f31c9703 (patch)
tree2d93db4165595b87adf6bfa5616289d1e4ef0be1
parent254a559e3cec92e2fda142e176114d3cf46570f6 (diff)
downloadaur-46d73a85c241b5e19521af689024ab25f31c9703.tar.gz
add systemd unit
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a851540a06b8..5d9324216eda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,6 +28,10 @@ build() {
}
package() {
+ install -m755 -d "$pkgdir"/usr/lib/systemd/system
+ install -m644 $_pkgname/services/systemd/gimmeasearx.service "$pkgdir"/usr/lib/systemd/system/gimmeasearx.service
+ sed -i s,TEMPLATE_DIR,/var/lib/gimmeasearx, "$pkgdir"/usr/lib/systemd/system/gimmeasearx.service
+
install -Dm 755 /dev/stdin "$pkgdir"/usr/bin/$_pkgname <<EOF
#!/bin/sh
cd /var/lib/gimmeasearx