summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Holierhoek2015-09-04 20:44:57 +0200
committerDennis Holierhoek2015-09-04 20:44:57 +0200
commiteaeeb927f4eca80496c12187d2f5e00c3eafce7a (patch)
tree8fb762507053cd00320b12b7e0f089c1d0acf7a9
downloadaur-eaeeb927f4eca80496c12187d2f5e00c3eafce7a.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..959cae2876ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gimp-dds
+ pkgdesc = A plugin for the GIMP version 2.8. It allows you to load and save images in the Direct Draw Surface (DDS) format
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = https://code.google.com/p/gimp-dds
+ arch = any
+ license = GPL2
+ makedepends = pkg-config
+ depends = gimp>=2.8.x
+ depends = glib2
+ depends = gtk2
+ depends = pango
+ depends = atk
+ source = https://gimp-dds.googlecode.com/files/gimp-dds-3.0.1.tar.bz2
+ md5sums = 19a0310e97b93d836beb3239fa0cbd63
+ sha256sums = 6e53df3b8b98c55f22fa7ea2c3ed17478626c924b24c69d499f5d813c3c2788a
+
+pkgname = gimp-dds
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e9b9863b4d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Megameneer (Dennis Holierhoek) <dennis.hh@hotmail.com>
+pkgname=gimp-dds
+pkgver=3.0.1
+pkgrel=1
+pkgdesc="A plugin for the GIMP version 2.8. It allows you to load and save images in the Direct Draw Surface (DDS) format"
+arch=('any')
+url=https://code.google.com/p/gimp-dds
+license=('GPL2')
+depends=('gimp>=2.8.x' 'glib2' 'gtk2' 'pango' 'atk')
+makedepends=('pkg-config')
+source=(https://gimp-dds.googlecode.com/files/gimp-dds-3.0.1.tar.bz2)
+md5sums=('19a0310e97b93d836beb3239fa0cbd63')
+sha256sums=('6e53df3b8b98c55f22fa7ea2c3ed17478626c924b24c69d499f5d813c3c2788a')
+
+build() {
+ cd gimp-dds-$pkgver
+ make
+}
+
+package() {
+ cd "$srcdir"/gimp-dds-"$pkgver"
+ install -dm755 "$pkgdir"/usr/share/gimp/2.0
+ cp --no-preserve=mode dds "$pkgdir"/usr/share/gimp/2.0/
+}