summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsu2262022-11-16 22:18:11 +0800
committersu2262022-11-16 22:18:11 +0800
commit58e77c324f79fc6250efd98d3a57fae8c6874d64 (patch)
tree67cb9eafe07b16ed5b101ad23dc1f8da334aee67
parent5167ce8d103f82a63a7e9ca0bd046e2473fdfb7c (diff)
downloadaur-58e77c324f79fc6250efd98d3a57fae8c6874d64.tar.gz
Update to 2.99.14
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
-rw-r--r--file-heif.diff40
3 files changed, 14 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2acd6ceb615e..61e749aa24c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gimp-devel-noconflict
pkgdesc = GNU Image Manipulation Program (Development version, doesn't conflict with gimp 2.0)
- pkgver = 2.99.12
+ pkgver = 2.99.14
pkgrel = 1
url = https://www.gimp.org/
arch = i686
@@ -71,12 +71,10 @@ pkgbase = gimp-devel-noconflict
optdepends = gjs: JavaScript scripting support
optdepends = luajit: LUA scripting support
optdepends = lua51-lgi: LUA scripting support
- provides = gimp=2.99.12
- source = https://download.gimp.org/pub/gimp/v2.99/gimp-2.99.12.tar.xz
+ provides = gimp=2.99.14
+ source = https://download.gimp.org/pub/gimp/v2.99/gimp-2.99.14.tar.xz
source = linux.gpl
- source = file-heif.diff
- sha256sums = 7ba1b032ea520d540e4acad3da16d8637fe693743fdb36e0121775eea569f6a3
+ sha256sums = 313a205475d1ff03c5c4d9602f09f5c975ba6c1c79d8843e2396f9fe2abdf7a8
sha256sums = 1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3
- sha256sums = 4996eedcf6d8238c21c52c70ac4b3027f007b2a2a8f1eab9a0caaee6989dcc35
pkgname = gimp-devel-noconflict
diff --git a/PKGBUILD b/PKGBUILD
index ad14da2132d7..41f8082ada87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=gimp
pkgname=${_pkgname}-devel-noconflict
-pkgver=2.99.12
+pkgver=2.99.14
pkgrel=1
pkgdesc="GNU Image Manipulation Program (Development version, doesn't conflict with gimp 2.0)"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -35,17 +35,11 @@ optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cu
'lua51-lgi: LUA scripting support')
provides=("${_pkgname}=${pkgver}")
source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}.tar.xz
- linux.gpl
- file-heif.diff)
-sha256sums=('7ba1b032ea520d540e4acad3da16d8637fe693743fdb36e0121775eea569f6a3'
- '1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3'
- '4996eedcf6d8238c21c52c70ac4b3027f007b2a2a8f1eab9a0caaee6989dcc35')
+ linux.gpl)
+sha256sums=('313a205475d1ff03c5c4d9602f09f5c975ba6c1c79d8843e2396f9fe2abdf7a8'
+ '1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
build() {
- local _dir="${_pkgname}-${pkgver}"
- # fix builing with libheif 1.13.0+
- # see https://gitlab.gnome.org/GNOME/gimp/-/issues/8570
- patch "$_dir/plug-ins/common/file-heif.c" < file-heif.diff
- arch-meson "$_dir" build \
+ arch-meson "${_pkgname}-${pkgver}" build \
-Dgi-docgen=enabled \
-Dg-ir-doc=true
meson compile -C build
@@ -72,4 +66,9 @@ package() {
rm "${pkgdir}/usr/share/man/man1/gimp.1"
rm "${pkgdir}/usr/share/man/man1/gimptool.1"
rm "${pkgdir}/usr/share/man/man5/gimprc.5"
+ rm "${pkgdir}/usr/bin/gimp"
+ rm "${pkgdir}/usr/bin/gimp-console"
+ rm "${pkgdir}/usr/bin/gimp-test-clipboard"
+ rm "${pkgdir}/usr/bin/gimptool"
+ rm "${pkgdir}/usr/lib/gimp-debug-tool"
}
diff --git a/file-heif.diff b/file-heif.diff
deleted file mode 100644
index afdca2703e5c..000000000000
--- a/file-heif.diff
+++ /dev/null
@@ -1,40 +0,0 @@
-59,60c59,60
-< typedef struct _Heif Heif;
-< typedef struct _HeifClass HeifClass;
----
-> typedef struct _GimpHeif GimpHeif;
-> typedef struct _GimpHeifClass GimpHeifClass;
-62c62
-< struct _Heif
----
-> struct _GimpHeif
-67c67
-< struct _HeifClass
----
-> struct _GimpHeifClass
-73,74c73,74
-< #define HEIF_TYPE (heif_get_type ())
-< #define HEIF (obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), HEIF_TYPE, Heif))
----
-> #define GIMP_HEIF_TYPE (gimp_heif_get_type ())
-> #define GIMP_HEIF (obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), GIMP_HEIF_TYPE, GimpHeif))
-76c76
-< GType heif_get_type (void) G_GNUC_CONST;
----
-> GType gimp_heif_get_type (void) G_GNUC_CONST;
-126c126
-< G_DEFINE_TYPE (Heif, heif, GIMP_TYPE_PLUG_IN)
----
-> G_DEFINE_TYPE (GimpHeif, gimp_heif, GIMP_TYPE_PLUG_IN)
-128c128
-< GIMP_MAIN (HEIF_TYPE)
----
-> GIMP_MAIN (GIMP_HEIF_TYPE)
-133c133
-< heif_class_init (HeifClass *klass)
----
-> gimp_heif_class_init (GimpHeifClass *klass)
-143c143
-< heif_init (Heif *heif)
----
-> gimp_heif_init (GimpHeif *heif)