summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElMastro2023-11-11 19:01:07 +0100
committerElMastro2023-11-11 19:01:07 +0100
commit180f0bd43ee951886cf36ab034a2e92ef3208912 (patch)
treefabc60cac8343d5e0cfa195ab79752f82d1d7f33
parent8d90526a79351faed007ea90fb26fac3ae6370ce (diff)
downloadaur-gimp-gap.tar.gz
fixed for the last version of gimp
-rwxr-xr-x.SRCINFO13
-rw-r--r--[-rwxr-xr-x]PKGBUILD51
2 files changed, 42 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64208159f929..83e2a4afc751 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = gimp-gap
pkgdesc = Gimp Animation Package, gimp's plugin for animation
pkgver = 2.7
- pkgrel = 1
+ pkgrel = 2
url = https://www.gimp.org/tutorials/Using_GAP/
arch = x86_64
arch = i686
- license = GPLv3
+ license = GPL3
makedepends = intltool
- makedepends = cmake
+ makedepends = git
depends = gimp>=2.6.0
depends = glib2
optdepends = xvidcore: compression codec
@@ -16,8 +16,11 @@ pkgbase = gimp-gap
optdepends = faad2: audio decoder
optdepends = lame: mpeg layer 3 codec
optdepends = libx264: H264 codec
- source = git+https://github.com/GNOME/gimp-gap
+ optdepends = mplayer: frames extraction
+ options = !buildflags
+ source = git+https://gitlab.gnome.org/Archive/gimp-gap.git
+ source = effadce6c756247ea8bae32dc13bb3e6f464f0eb.patch::https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/effadce6c756247ea8bae32dc13bb3e6f464f0eb
md5sums = SKIP
+ md5sums = 955ac456a53dbb221b7e2a87ab5a93f6
pkgname = gimp-gap
-
diff --git a/PKGBUILD b/PKGBUILD
index 78b4b0957160..0a76ef570895 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,44 @@
-#Maintainer: M. Mastroeni <the_maxtro@hotmail.it>
+#Maintainer: M. Mastroeni <the_maxtro AT hotmail DOT it>
pkgname=gimp-gap
pkgver=2.7
-pkgrel=1
+pkgrel=2
pkgdesc="Gimp Animation Package, gimp's plugin for animation"
url="https://www.gimp.org/tutorials/Using_GAP/"
arch=('x86_64' 'i686')
-license=('GPLv3' )
+license=('GPL3')
depends=('gimp>=2.6.0' 'glib2')
-makedepends=( 'intltool' 'cmake')
+makedepends=('intltool' 'git')
optdepends=('xvidcore: compression codec'
- 'lbzip2: data compressor'
- 'faac: audio encoder'
- 'faad2: audio decoder'
- 'lame: mpeg layer 3 codec'
- 'libx264: H264 codec')
-source=('git+https://github.com/GNOME/gimp-gap')
-md5sums=('SKIP')
+ 'lbzip2: data compressor'
+ 'faac: audio encoder'
+ 'faad2: audio decoder'
+ 'lame: mpeg layer 3 codec'
+ 'libx264: H264 codec'
+ 'mplayer: frames extraction')
+options=(!buildflags)
+source=('git+https://gitlab.gnome.org/Archive/gimp-gap.git'
+ effadce6c756247ea8bae32dc13bb3e6f464f0eb.patch::https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/effadce6c756247ea8bae32dc13bb3e6f464f0eb)
+md5sums=('SKIP'
+ '955ac456a53dbb221b7e2a87ab5a93f6')
+
+prepare() {
+ cd $pkgname
+ bsdtar -xf extern_libs/ffmpeg.tar.gz -C extern_libs
+ # fix building with binutil >= 2.41
+ patch -Np1 -i "$srcdir/effadce6c756247ea8bae32dc13bb3e6f464f0eb.patch" -d extern_libs/ffmpeg
+ # fix library linking order
+ sed -i 's/$FFMPEG_LIBAVUTIL_A $FFMPEG_LIBSWSCALE_A/$FFMPEG_LIBSWSCALE_A $FFMPEG_LIBAVUTIL_A/' configure.in
+ autoreconf -vfi
+}
+
+build() {
+ cd $pkgname
+ export LIBS='-lm'
+ ./configure --prefix=/usr --with-ffmpegsrcdir="$PWD"/extern_libs/ffmpeg
+ make -j1
+}
package() {
- cd "${srcdir}/gimp-gap"
- ./autogen.sh CC="gcc" CXX="g++" LDFLAGS="-lm" CFLAGS="-g"
- cmake
- make
- make DESTDIR="${pkgdir}" install
- rmdir "${pkgdir}/usr/local/lib/gimp-gap-2.7"
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
}