aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFFY002018-07-15 15:42:01 +0100
committerFFY002018-07-15 15:42:01 +0100
commit317ee147986ae91962fb30886ebdcd06087c2f09 (patch)
treed6ea9914a9a117ff6b226fdc108359f047577d29
parentb52bb23aea4b0b0ae66419742d5c1b874f228104 (diff)
downloadaur-317ee147986a.tar.gz
pkgbuild: use autoreconf
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD56
2 files changed, 28 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c25fafdcc5fa..e5e8f696692d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = gimp-git
pkgdesc = GNU Image Manipulation Program
- pkgver = 2.10.2.647.g8e6a5298c1
+ pkgver = 2.10.2.1075.gb4c244b839
pkgrel = 1
epoch = 1
- url = http://www.gimp.org
+ url = https://www.gimp.org
arch = i686
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 2c241076d2c8..c58bcf0d2dda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,41 +4,31 @@
# Contributor: Alessio Biancalana <dottorblaster@gmail.com>
pkgname=gimp-git
epoch=1
-pkgver=2.10.2.647.g8e6a5298c1
+pkgver=2.10.2.1075.gb4c244b839
pkgrel=1
pkgdesc="GNU Image Manipulation Program"
arch=('i686' 'x86_64')
-url="http://www.gimp.org"
+url="https://www.gimp.org"
license=('GPL' 'LGPL')
-depends=(
- 'pygtk' 'lcms2>=2.2' 'libwmf>=0.2.8'
- 'libgexiv2' 'librsvg>=2.16.1' 'desktop-file-utils'
- 'libexif>=0.6.15' 'libart-lgpl>=2.3.19' 'dbus-glib' 'gtk-doc'
- 'poppler-glib' 'poppler-data' 'openexr>=1.6.1' 'mypaint-brushes>=1.3.0'
- 'babl>=0.1.46' 'gegl-git>0.4.0' 'icu' 'enchant' 'appstream-glib>=0.7.7'
-)
-makedepends=(
- 'git' 'gutenprint>=5.0.0' 'intltool>=0.40.1'
- 'gnome-python>=2.16.2'
- 'alsa-lib>=1.0.0' 'libxslt' 'glib-networking'
-)
-optdepends=(
- 'gutenprint: for sophisticated printing only as gimp has built-in cups print support'
- 'alsa-lib: for MIDI event controller module'
- 'curl: for URI support'
- 'ghostscript: for postscript support'
-)
+depends=('pygtk' 'lcms2>=2.2' 'libwmf>=0.2.8'
+ 'libgexiv2' 'librsvg>=2.16.1' 'desktop-file-utils'
+ 'libexif>=0.6.15' 'libart-lgpl>=2.3.19' 'dbus-glib' 'gtk-doc'
+ 'poppler-glib' 'poppler-data' 'openexr>=1.6.1' 'mypaint-brushes>=1.3.0'
+ 'babl>=0.1.46' 'gegl-git>0.4.0' 'icu' 'enchant' 'appstream-glib>=0.7.7')
+makedepends=('git' 'gutenprint>=5.0.0' 'intltool>=0.40.1'
+ 'gnome-python>=2.16.2'
+ 'alsa-lib>=1.0.0' 'libxslt' 'glib-networking')
+optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
+ 'alsa-lib: for MIDI event controller module'
+ 'curl: for URI support'
+ 'ghostscript: for postscript support')
options=('!libtool')
provides=('gimp')
conflicts=('gimp')
-source=(
- 'git+https://gitlab.gnome.org/GNOME/gimp.git'
- 'linux.gpl'
-)
-sha256sums=(
- 'SKIP'
- '1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3'
-)
+source=('git+https://gitlab.gnome.org/GNOME/gimp.git'
+ 'linux.gpl')
+sha256sums=('SKIP'
+ '1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
_gitname=gimp
@@ -47,17 +37,23 @@ pkgver() {
git describe --always | sed -e 's/GIMP_//' -e 's/[_-]/./g'
}
-build() {
+prepare() {
cd "$srcdir"/$_gitname
if [ -f /usr/lib/pkgconfig/libmypaint-1.3.pc ]; then
sed -i 's/libmypaint /libmypaint-1.3 /g' configure.ac
fi
- PYTHON=/usr/bin/python2 ./autogen.sh --prefix=/usr --sysconfdir=/etc \
+ PYTHON=/usr/bin/python2 autoreconf -if
+
+ ./configure --prefix=/usr --sysconfdir=/etc \
--enable-mp --enable-gimp-console --enable-gimp-remote \
--enable-python --with-gif-compression=lzw --with-libcurl \
--without-aa --without-hal --without-gvfs --without-gnomevfs
+}
+
+build() {
+ cd "$srcdir"/$_gitname
PYTHONPATH=/usr/share/glib-2.0:$PYTHONPATH make
}