aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFFY002018-09-15 16:01:08 +0100
committerFFY002018-09-15 16:01:08 +0100
commit33dda73794fd04f29e5470bb1d37198b859fb33c (patch)
treedf234c4859c06c0e676ac286e0f66039f73e2ece
parent7aa627d5df433a6152f8081d50ae3c3e4573a4ce (diff)
downloadaur-33dda73794fd04f29e5470bb1d37198b859fb33c.tar.gz
fix pkgver
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD57
2 files changed, 64 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e30903468eeb..71ced550c872 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gimp-git
pkgdesc = GNU Image Manipulation Program
- pkgver = 2.99.1.5483ea8
+ pkgver = 3.0.r42265.ff56a3af8d
pkgrel = 1
epoch = 1
url = https://www.gimp.org
@@ -8,6 +8,7 @@ pkgbase = gimp-git
arch = x86_64
license = GPL
license = LGPL
+ checkdepends = xorg-server-xvfb
makedepends = git
makedepends = gutenprint>=5.0.0
makedepends = intltool>=0.40.1
@@ -15,6 +16,17 @@ pkgbase = gimp-git
makedepends = alsa-lib>=1.0.0
makedepends = libxslt
makedepends = glib-networking
+ makedepends = alsa-lib
+ makedepends = curl
+ makedepends = ghostscript
+ makedepends = libxpm
+ makedepends = webkit2gtk
+ makedepends = libheif
+ makedepends = libwebp
+ makedepends = libmng
+ makedepends = iso-codes
+ makedepends = aalib
+ makedepends = zlib
depends = pygtk
depends = lcms2>=2.2
depends = libwmf>=0.2.8
@@ -31,17 +43,24 @@ pkgbase = gimp-git
depends = poppler-data
depends = openexr>=1.6.1
depends = mypaint-brushes>=1.3.0
- depends = babl>=0.1.47
- depends = gegl>0.4.9
+ depends = babl>=0.1.57
+ depends = gegl>=0.4.9
depends = cairo>=1.14
depends = appstream-glib>=0.7.7
optdepends = gutenprint: for sophisticated printing only as gimp has built-in cups print support
optdepends = alsa-lib: for MIDI event controller module
optdepends = curl: for URI support
optdepends = ghostscript: for postscript support
+ optdepends = libxpm: XPM support
+ optdepends = webkit2gtk: HTML renderer and web content engine
+ optdepends = libheif: HEIF support
+ optdepends = libwebp: WebP support
+ optdepends = libmng: MNG support
+ optdepends = iso-codes: Language support
+ optdepends = aalib: ASCII art support
+ optdepends = zlib: Compression routines
provides = gimp
conflicts = gimp
- options = !libtool
source = git+https://gitlab.gnome.org/GNOME/gimp.git
source = linux.gpl
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 488b199e32ec..779538a2897c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
# Contributor: Iru Cai <mytbk920423@gmail.com>
# Contributor: Alexander Hunziker <alex.hunziker@gmail.com>
# Contributor: Alessio Biancalana <dottorblaster@gmail.com>
+
pkgname=gimp-git
_pkgname=${pkgname%-git}
epoch=1
-pkgver=2.99.1.5483ea8
+pkgver=3.0.r42265.ff56a3af8d
pkgrel=1
pkgdesc="GNU Image Manipulation Program"
arch=('i686' 'x86_64')
@@ -15,15 +16,24 @@ depends=('pygtk' 'lcms2>=2.2' 'libwmf>=0.2.8' 'icu' 'enchant'
'libgexiv2' 'librsvg>=2.16.1' 'desktop-file-utils'
'libexif>=0.6.15' 'libart-lgpl>=2.3.19' 'dbus-glib' 'gtk-doc'
'poppler-glib' 'poppler-data' 'openexr>=1.6.1' 'mypaint-brushes>=1.3.0'
- 'babl>=0.1.47' 'gegl>0.4.9' 'cairo>=1.14' 'appstream-glib>=0.7.7')
-makedepends=('git' 'gutenprint>=5.0.0' 'intltool>=0.40.1'
- 'gnome-python>=2.16.2'
- 'alsa-lib>=1.0.0' 'libxslt' 'glib-networking')
+ 'babl>=0.1.57' 'gegl>=0.4.9' 'cairo>=1.14' 'appstream-glib>=0.7.7')
+makedepends=('git' 'gutenprint>=5.0.0' 'intltool>=0.40.1' 'gnome-python>=2.16.2'
+ 'alsa-lib>=1.0.0' 'libxslt' 'glib-networking'
+ 'alsa-lib' 'curl' 'ghostscript' 'libxpm' 'webkit2gtk'
+ 'libheif' 'libwebp' 'libmng' 'iso-codes' 'aalib' 'zlib')
+checkdepends=('xorg-server-xvfb')
optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
'alsa-lib: for MIDI event controller module'
'curl: for URI support'
- 'ghostscript: for postscript support')
-options=('!libtool')
+ 'ghostscript: for postscript support'
+ 'libxpm: XPM support'
+ 'webkit2gtk: HTML renderer and web content engine'
+ 'libheif: HEIF support'
+ 'libwebp: WebP support'
+ 'libmng: MNG support'
+ 'iso-codes: Language support'
+ 'aalib: ASCII art support'
+ 'zlib: Compression routines')
provides=('gimp')
conflicts=('gimp')
source=('git+https://gitlab.gnome.org/GNOME/gimp.git'
@@ -34,31 +44,36 @@ sha512sums=('SKIP'
pkgver() {
cd $_pkgname
- echo $(cat configure.ac | grep '^m4_define(\[gimp_api_version\], \[.*\])' | sed -e 's|m4_define(\[gimp_api_version\], \[||' -e 's|\])||').$(git log --pretty=format:'%h' -n 1)
+ printf "%s.r%s.%s" \
+ $(cat configure.ac | grep '^m4_define(\[gimp_api_version\], \[.*\])' | sed -e 's|m4_define(\[gimp_api_version\], \[||' -e 's|\])||') \
+ $(git rev-list --count HEAD) \
+ $(git rev-parse --short HEAD)
}
prepare() {
cd $_pkgname
- if [ -f /usr/lib/pkgconfig/libmypaint-1.3.pc ]; then
- sed -i 's/libmypaint /libmypaint-1.3 /g' configure.ac
- fi
+ _mypaintver=$(echo /usr/lib/libmypaint-*.so | grep -o -E '\-[0-9]+(\.[0-9]+)*' | head -1)
+ sed -i "s|\\(libmypaint\\)\\( >= libmypaint_required_version\\)|\\1${_mypaintver}\\2|g" configure.ac
+
+ export PYTHON=/usr/bin/python2
- PYTHON=/usr/bin/python2 autoreconf -if
+ autoreconf -vif
./configure \
--prefix=/usr \
--sysconfdir=/etc \
+ --libexecdir=/usr/bin \
--enable-mp \
--enable-gimp-console \
--enable-gimp-remote \
--enable-python \
+ --enable-gtk-doc \
--with-gif-compression=lzw \
--with-libcurl \
- --without-aa \
- --without-hal \
- --without-gvfs \
- --without-gnomevfs
+ --with-openexr
+
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
}
build() {
@@ -67,11 +82,21 @@ build() {
PYTHONPATH=/usr/share/glib-2.0:$PYTHONPATH make
}
+#check() {
+# cd $_pkgname
+#
+# xvfb-run make check
+# xvfb-run make distcheck
+#}
+
package() {
cd $_pkgname
make DESTDIR="$pkgdir" install
install -Dm 644 "$srcdir"/linux.gpl "$pkgdir"/usr/share/gimp/2.0/palettes/Linux.gpl
+
+ ln -s gimptool-2.0 "$pkgdir"/usr/bin/gimptool
+ ln -sf gimptool-2.0.1.gz "$pkgdir"/usr/share/man/man1/gimptool.1.gz
}