aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-08-01 22:01:19 +0200
committerbartus2019-09-16 21:49:33 +0200
commit63600e11b3459425b36a1f3780d06eb8481fd377 (patch)
treeca13959345a16fccb1d6dc21d17e1d85999ccb48
parent45b93d40b1b11208e228057daa6cd8ddb7d74bf0 (diff)
downloadaur-63600e11b3459425b36a1f3780d06eb8481fd377.tar.gz
fix autotools invocation and deps
* replace autreconf/configure with autogen.sh * add gobject-introspection dependency * update update.PKGBUILD
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--PKGBUILD.in7
-rwxr-xr-xupdate.PKGBUILD2
4 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee382115931a..7377e6916e08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gimp-develop-git
pkgdesc = GNU Image Manipulation Program (non-conflicting git version)
- pkgver = 2.99.1.r2590.928b85d25c
+ pkgver = 2.99.1.r2925.71d0251d2c
pkgrel = 1
epoch = 1
url = https://www.gimp.org
@@ -42,10 +42,11 @@ pkgbase = gimp-develop-git
depends = poppler-data>=0.4.9
depends = openexr>=1.6.1
depends = mypaint-brushes>=1.3.0
- depends = babl>=0.1.66
+ depends = babl>=0.1.68
depends = gegl>=0.4.17
depends = cairo>=1.14.0
depends = appstream-glib>=0.7.7
+ depends = gobject-introspection>=1.32.0
optdepends = gutenprint: for sophisticated printing only as gimp has built-in cups print support
optdepends = alsa-lib: for MIDI event controller module
optdepends = curl: for URI support
diff --git a/PKGBUILD b/PKGBUILD
index ff257ce5bfcf..a62c8bf3cdc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=gimp-develop-git
_pkgname=${pkgname%-develop-git}
epoch=1
-pkgver=2.99.1.r2590.928b85d25c
+pkgver=2.99.1.r2925.71d0251d2c
pkgrel=1
pkgdesc="GNU Image Manipulation Program (non-conflicting git version)"
arch=('i686' 'x86_64')
@@ -30,10 +30,11 @@ depends=(
'poppler-data>=0.4.9'
'openexr>=1.6.1'
'mypaint-brushes>=1.3.0'
- 'babl>=0.1.66'
+ 'babl>=0.1.68'
'gegl>=0.4.17'
'cairo>=1.14.0'
'appstream-glib>=0.7.7'
+ 'gobject-introspection>=1.32.0'
)
makedepends=('git' 'gutenprint>=5.0.0' 'intltool>=0.40.1'
'alsa-lib>=1.0.0' 'libxslt' 'glib-networking'
@@ -68,11 +69,7 @@ prepare() {
_mypaintver=$(echo /usr/lib/libmypaint-*.so | grep -o -E '\-[0-9]+(\.[0-9]+)*' | head -1)
sed -i "s|\\(libmypaint\\)\\( >= libmypaint_required_version\\)|\\1${_mypaintver}\\2|g" configure.ac
- export PYTHON=/usr/bin/python2
-
- autoreconf -vif
-
- ./configure \
+ ./autogen.sh \
--prefix=/usr \
--sysconfdir=/etc \
--libexecdir=/usr/bin \
diff --git a/PKGBUILD.in b/PKGBUILD.in
index 7090f120db82..6d74ce23b36e 100644
--- a/PKGBUILD.in
+++ b/PKGBUILD.in
@@ -34,6 +34,7 @@ depends=(
'gegl>=@_gegl_version@'
'cairo>=@_cairo_version@'
'appstream-glib>=@_appstream_glib_version@'
+ 'gobject-introspection>=@_introspection_version@'
)
makedepends=('git' 'gutenprint>=5.0.0' 'intltool>=0.40.1'
'alsa-lib>=1.0.0' 'libxslt' 'glib-networking'
@@ -68,11 +69,7 @@ prepare() {
_mypaintver=$(echo /usr/lib/libmypaint-*.so | grep -o -E '\-[0-9]+(\.[0-9]+)*' | head -1)
sed -i "s|\\(libmypaint\\)\\( >= libmypaint_required_version\\)|\\1${_mypaintver}\\2|g" configure.ac
- export PYTHON=/usr/bin/python2
-
- autoreconf -vif
-
- ./configure \
+ ./autogen.sh \
--prefix=/usr \
--sysconfdir=/etc \
--libexecdir=/usr/bin \
diff --git a/update.PKGBUILD b/update.PKGBUILD
index a0036f7baa80..66e9882ad5e5 100755
--- a/update.PKGBUILD
+++ b/update.PKGBUILD
@@ -4,7 +4,7 @@ _gitname=gimp
srcdir=$PWD/src
declare -A dep_versions
-readonly -a deps=(pygtk gexiv2 poppler poppler_data libmypaint gtkdoc cairo babl lcms wmf gexiv2 rsvg openexr libmypaint appstream_glib)
+readonly -a deps=(pygtk gexiv2 poppler poppler_data libmypaint gtkdoc cairo babl lcms wmf gexiv2 rsvg openexr libmypaint appstream_glib introspection)
## probe configure.ac for dependencies versions
# gegl version is broken to major_minor|micro those need to be probled separately