summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatrio2016-01-10 12:36:04 +0300
committerNatrio2016-01-10 12:36:04 +0300
commit55269c13ec05589ba7672cf9bb91e0586683176c (patch)
tree954339bd4a6ee0f718aa50e795ff420fe3e43da0
parent92a48f3e8c9b19e186bb303ef6ba10dc2703e7b6 (diff)
downloadaur-55269c13ec05589ba7672cf9bb91e0586683176c.tar.gz
8.0-2, fixed "strndup()" duplicated declaration.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--stop-declare-strndup.patch11
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a211eb09a41..4c5354953fe2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by makepkg 4.2.1
+# Sun Jan 10 09:10:20 UTC 2016
pkgbase = gimp-plugin-astronomy
pkgdesc = Gimp Astronomy Plugins
pkgver = 0.8
- pkgrel = 1
+ pkgrel = 2
url = http://hennigbuam.de/georg/gimp.html
arch = i686
arch = x86_64
@@ -11,7 +13,9 @@ pkgbase = gimp-plugin-astronomy
depends = gsl
depends = fftw
source = http://www.hennigbuam.de/georg/downloads/gimp-plugin-astronomy-0.8.tar.bz2
+ source = stop-declare-strndup.patch
md5sums = 8396e97e9f369a5139d0102b5f37b620
+ md5sums = SKIP
pkgname = gimp-plugin-astronomy
diff --git a/PKGBUILD b/PKGBUILD
index a2d81c12e473..e6800fc0f24d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Maintainer: Natrio <natrio list ru>
pkgname=gimp-plugin-astronomy
pkgver=0.8
-pkgrel=1
+pkgrel=2
pkgdesc="Gimp Astronomy Plugins"
arch=('i686' 'x86_64')
url="http://hennigbuam.de/georg/gimp.html"
license=('GPL')
depends=('gimp' 'gsl' 'fftw')
makedepends=('perl-xml-parser')
-source=("http://www.hennigbuam.de/georg/downloads/$pkgname-$pkgver.tar.bz2")
-md5sums=('8396e97e9f369a5139d0102b5f37b620')
+source=("http://www.hennigbuam.de/georg/downloads/$pkgname-$pkgver.tar.bz2"
+ 'stop-declare-strndup.patch')
+md5sums=('8396e97e9f369a5139d0102b5f37b620' SKIP)
build() {
cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/stop-declare-strndup.patch"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make LIBS='-lm'
}
diff --git a/stop-declare-strndup.patch b/stop-declare-strndup.patch
new file mode 100644
index 000000000000..2823bc1b345b
--- /dev/null
+++ b/stop-declare-strndup.patch
@@ -0,0 +1,11 @@
+diff -pur 1/src/merge.c 2/src/merge.c
+--- 1/src/merge.c 2012-10-07 14:12:09.000000000 +0400
++++ 2/src/merge.c 2016-01-10 12:05:08.867173581 +0300
+@@ -30,7 +30,6 @@ of median +- sigma or sigma median (1 or
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+-char *strndup(const char *s, size_t n);
+
+ #include <libgimp/gimp.h>
+ #include <libgimp/gimpui.h>