summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSetsuna Watanabe2022-12-09 16:15:13 -0700
committerSetsuna Watanabe2022-12-09 16:15:13 -0700
commitf3b069c3fbbb28641cfb23d9c17542985ddb502a (patch)
tree529907e8f62077653dd0c0416c1da6f68eb8c3d6
parent3f37cd5939014de5337c01ebf7e397225a0f99ed (diff)
downloadaur-gimp-plugin-beautify.tar.gz
Change version scheme to match upstream; Add signature check; Clean up build()
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD39
2 files changed, 15 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e82b5e55bb87..a5486f6525d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = gimp-plugin-beautify
pkgdesc = GIMP Beautify is a set of GIMP plug-ins for quickly and easily beautifying photos.
- pkgver = 20121117
- pkgrel = 2
- epoch = 0
+ pkgver = 0.5.3
+ pkgrel = 1
url = https://github.com/hejiann/beautify
arch = i686
arch = x86_64
license = GPL3
- makedepends = git
depends = gimp
+ source = gimp-plugin-beautify-0.5.3.tar.gz::https://github.com/hejiann/beautify/archive/v0.5.3.tar.gz
+ md5sums = 48a90327c487093df19654f4ab95e4d5
-pkgname = gimp-plugin-beautify
+pkgname = gimp-plugin-beautify \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 21f90280f6ca..7a2399194648 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,44 +2,25 @@
# Contributor: Liu Yuyang <lhtlyy at googlemail dot com>
pkgname=gimp-plugin-beautify
-pkgver=20121117
-pkgrel=2
-epoch=0
+pkgver=0.5.3
+pkgrel=1
pkgdesc="GIMP Beautify is a set of GIMP plug-ins for quickly and easily beautifying photos."
arch=('i686' 'x86_64')
url="https://github.com/hejiann/beautify"
license=('GPL3')
depends=('gimp')
-makedepends=('git')
-
-_gitroot="https://github.com/hejiann/beautify.git"
-_gitname="beautify"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/hejiann/beautify/archive/v$pkgver.tar.gz")
+md5sums=('48a90327c487093df19654f4ab95e4d5')
build() {
- cd "$srcdir"
- msg "Connecting to Git server..."
-
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot $_gitname
- fi
-
- msg "Git checkout done or server timeout."
- msg "Starting make..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
-
+ cd "beautify-$pkgver"
make
}
package() {
- cd "$srcdir/$_gitname-build"
- install -Dm 755 "$srcdir/$_gitname-build/beautify" "$pkgdir/usr/lib/gimp/2.0/plug-ins/beautify"
- install -Dm 755 "$srcdir/$_gitname-build/skin-whitening" "$pkgdir/usr/lib/gimp/2.0/plug-ins/skin-whitening"
- install -Dm 755 "$srcdir/$_gitname-build/simple-border" "$pkgdir/usr/lib/gimp/2.0/plug-ins/simple-border"
- install -Dm 755 "$srcdir/$_gitname-build/border" "$pkgdir/usr/lib/gimp/2.0/plug-ins/border"
+ cd "beautify-$pkgver"
+ install -Dm755 beautify "$pkgdir/usr/lib/gimp/2.0/plug-ins/beautify"
+ install -Dm755 skin-whitening "$pkgdir/usr/lib/gimp/2.0/plug-ins/skin-whitening"
+ install -Dm755 simple-border "$pkgdir/usr/lib/gimp/2.0/plug-ins/simple-border"
+ install -Dm755 border "$pkgdir/usr/lib/gimp/2.0/plug-ins/border"
} \ No newline at end of file