summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSetsuna Watanabe2022-12-09 16:00:31 -0700
committerSetsuna Watanabe2022-12-09 16:00:31 -0700
commit3f37cd5939014de5337c01ebf7e397225a0f99ed (patch)
tree0df9b568f8dc7f192b8aea271dac81487ff1c048
parent6fde427011134e3bd92b11470ee443e00ab698ed (diff)
downloadaur-3f37cd5939014de5337c01ebf7e397225a0f99ed.tar.gz
Change protocol from Git to HTTPS
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 9 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a78d4aa52837..e82b5e55bb87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gimp-plugin-beautify
- pkgdesc = GIMP Beautify is a set of GIMP plug-ins for quickly and easily beautify photo
+ pkgdesc = GIMP Beautify is a set of GIMP plug-ins for quickly and easily beautifying photos.
pkgver = 20121117
- pkgrel = 1
+ pkgrel = 2
epoch = 0
url = https://github.com/hejiann/beautify
arch = i686
@@ -11,4 +11,3 @@ pkgbase = gimp-plugin-beautify
depends = gimp
pkgname = gimp-plugin-beautify
-
diff --git a/PKGBUILD b/PKGBUILD
index ce534e52fc35..21f90280f6ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
+# Maintainer: Setsuna Watanabe <settyness at gmail dot com>
# Contributor: Liu Yuyang <lhtlyy at googlemail dot com>
-# Maintainer:Liu Yuyang <lhtlyy at googlemail dot com>
pkgname=gimp-plugin-beautify
pkgver=20121117
-pkgrel=1
+pkgrel=2
epoch=0
-pkgdesc="GIMP Beautify is a set of GIMP plug-ins for quickly and easily beautify photo "
+pkgdesc="GIMP Beautify is a set of GIMP plug-ins for quickly and easily beautifying photos."
arch=('i686' 'x86_64')
url="https://github.com/hejiann/beautify"
license=('GPL3')
depends=('gimp')
makedepends=('git')
-_gitroot="git://github.com/hejiann/beautify.git"
+_gitroot="https://github.com/hejiann/beautify.git"
_gitname="beautify"
build() {
cd "$srcdir"
- msg "Connecting to GIT server...."
+ msg "Connecting to Git server..."
if [ -d $_gitname ] ; then
cd $_gitname && git pull origin
@@ -26,16 +26,13 @@ build() {
git clone $_gitroot $_gitname
fi
- msg "GIT checkout done or server timeout"
+ msg "Git checkout done or server timeout."
msg "Starting make..."
rm -rf "$srcdir/$_gitname-build"
git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
cd "$srcdir/$_gitname-build"
- #
- # BUILD HERE
- #
make
}
@@ -45,5 +42,4 @@ package() {
install -Dm 755 "$srcdir/$_gitname-build/skin-whitening" "$pkgdir/usr/lib/gimp/2.0/plug-ins/skin-whitening"
install -Dm 755 "$srcdir/$_gitname-build/simple-border" "$pkgdir/usr/lib/gimp/2.0/plug-ins/simple-border"
install -Dm 755 "$srcdir/$_gitname-build/border" "$pkgdir/usr/lib/gimp/2.0/plug-ins/border"
-}
-
+} \ No newline at end of file