summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikola Pavlica2020-01-06 16:07:43 +0100
committerNikola Pavlica2020-01-06 16:07:43 +0100
commit15fab3552ae135361f09ab23f2820d97da943c32 (patch)
tree9fd2984c8cf559d4e3f50d0287b9d68271120f20
parent71a42e34339c4db6498cd23e32f336e6e0d9e3e9 (diff)
downloadaur-15fab3552ae135361f09ab23f2820d97da943c32.tar.gz
fix PKGBUILD syntax, source repo and dependencies
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD62
2 files changed, 32 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83fe1466d408..cc5202663b48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,23 @@
pkgbase = gimp-plugin-deskew-git
pkgdesc = Auto straighten lines of text in scanned documents
pkgver = 1.1
- pkgrel = 3
- url = https://github.com/prokoudine/gimp-deskew-plugin
+ pkgrel = 4
+ url = https://github.com/gimp-plugins-justice/gimp-deskew-plugin
arch = x86_64
license = GPL
makedepends = git
+ makedepends = gcc
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = intltool
+ makedepends = gettext
depends = gimp
provides = gimp-plugin-deskew
conflicts = gimp-plugin-deskew
source = autogen.patch
+ source = git+https://github.com/gimp-plugins-justice/gimp-deskew-plugin
sha256sums = b64799de98d8089790752d35ad8b1b1c5bc387a725b21cf2bd08589b26258b58
+ sha256sums = SKIP
pkgname = gimp-plugin-deskew-git
diff --git a/PKGBUILD b/PKGBUILD
index 3412bea2e106..b61e56481cd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,44 @@
+# Maintainer: Nikola Pavlica <pavlica.nikola@gmail.com>
# Maintainer: Michael Mansell <michael.mansell@gmail.com>
# Maintainer: Gosha Tugai [SAL9000] <gosha.tugai@gmail.com>
# Contributor: Ross Melin <rdmelin@gmail.com>
# 1.1-2 : Updated autogen.sh.patch to handle newer versions of automake.
+# 1.1-4 : Updated and corrected the PKGBUILD to a newer format and changed the repository
pkgname=gimp-plugin-deskew-git
+_pkgname=gimp-deskew-plugin
pkgver=1.1
-pkgrel=3
+pkgrel=4
pkgdesc="Auto straighten lines of text in scanned documents"
arch=('x86_64')
-#(old) url="http://www.cubewano.org/gimp-deskew-plugin/"
-url="https://github.com/prokoudine/gimp-deskew-plugin"
+#(old old) url="http://www.cubewano.org/gimp-deskew-plugin/"
+#(old) url="https://github.com/prokoudine/gimp-deskew-plugin"
+url="https://github.com/gimp-plugins-justice/gimp-deskew-plugin"
license=('GPL')
depends=('gimp')
-makedepends=('git')
+makedepends=('git' 'gcc' 'automake' 'autoconf' 'intltool' 'gettext')
provides=('gimp-plugin-deskew')
conflicts=('gimp-plugin-deskew')
-source=('autogen.patch')
-sha256sums=('b64799de98d8089790752d35ad8b1b1c5bc387a725b21cf2bd08589b26258b58')
+source=('autogen.patch'
+ 'git+https://github.com/gimp-plugins-justice/gimp-deskew-plugin')
+sha256sums=('b64799de98d8089790752d35ad8b1b1c5bc387a725b21cf2bd08589b26258b58'
+ 'SKIP')
-_gitroot='git://github.com/prokoudine/gimp-deskew-plugin.git'
-_gitname='gimp-deskew-plugin'
-
-package() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
-
- #
- # BUILD HERE
- #
- # Of course it's incompatible with newest autoconf >_<
+prepare() {
+ cd "$srcdir/$_pkgname"
msg "Patching autogen.sh for autoconf-1.12"
- patch -u -F5 -N autogen.sh ../../autogen.patch
- msg "autogen.sh"
+ patch -u -F5 -N autogen.sh ../autogen.patch
./autogen.sh --prefix=/usr
- msg "make"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
make || return 1
- msg "make install"
- make DESTDIR="$pkgdir/" install
- # hack to correct broken make --install
- mv "$pkgdir/usr/usr/lib" "$pkgdir/usr"
- rmdir "$pkgdir/usr/usr"
}
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}