summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mansell2015-06-28 19:14:24 -0400
committerMichael Mansell2015-06-28 19:14:24 -0400
commitfd00c1ace56f2fb1b4fda74157a416cfffd8775f (patch)
treecc4cb94ce7ff4bc4245d08293b8108ecc76b90e7
downloadaur-fd00c1ace56f2fb1b4fda74157a416cfffd8775f.tar.gz
Initial Import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD61
-rw-r--r--autogen.sh.patch32
3 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0158d08305d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gimp-plugin-deskew-git
+ pkgdesc = Auto straighten lines of text in scanned documents
+ pkgver = 1.1
+ pkgrel = 2
+ url = https://github.com/prokoudine/gimp-deskew-plugin
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = gimp
+ provides = gimp-plugin-deskew
+ conflicts = gimp-plugin-deskew
+ source = autogen.sh.patch
+ md5sums = 90ce5c6a84fb8b67a034badad0dd6758
+
+pkgname = gimp-plugin-deskew-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2565630ed26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Michael Mansell <michael.mansell@gmail.com>
+# Maintainer: Gosha Tugai [SAL9000] <gosha.tugai@gmail.com>
+# Contributor: Ross Melin <rdmelin@gmail.com>
+
+# 1.1-2 : Updated autogen.sh.patch to handle newer versions of automake.
+
+pkgname=gimp-plugin-deskew-git
+pkgver=1.1
+pkgrel=2
+pkgdesc="Auto straighten lines of text in scanned documents"
+arch=('x86_64')
+#(old) url="http://www.cubewano.org/gimp-deskew-plugin/"
+url="https://github.com/prokoudine/gimp-deskew-plugin"
+license=('GPL')
+depends=('gimp')
+makedepends=('git')
+provides=('gimp-plugin-deskew')
+conflicts=('gimp-plugin-deskew')
+source=('autogen.sh.patch')
+md5sums=('90ce5c6a84fb8b67a034badad0dd6758')
+
+_gitroot='git://github.com/prokoudine/gimp-deskew-plugin.git'
+_gitname='gimp-deskew-plugin'
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ #
+ # BUILD HERE
+ #
+ # Of course it's incompatible with newest autoconf >_<
+ msg "Patching autogen.sh for autoconf-1.12"
+ patch -u -F5 -N autogen.sh ../../autogen.sh.patch
+ msg "autogen.sh"
+ ./autogen.sh --prefix=/usr
+ msg "make"
+ make || return 1
+ msg "make install"
+ make DESTDIR="$pkgdir/" install
+ # hack to correct broken make --install
+ mv $pkgdir/usr/usr/lib $pkgdir/usr/
+ rmdir $pkgdir/usr/usr
+}
+
+# vim:set ts=2 sw=2 et:
+
diff --git a/autogen.sh.patch b/autogen.sh.patch
new file mode 100644
index 000000000000..30ff6c5a9fa7
--- /dev/null
+++ b/autogen.sh.patch
@@ -0,0 +1,32 @@
+--- ../gimp-deskew-plugin/autogen.sh 2012-05-23 16:25:29.061601683 +0930
++++ autogen.sh 2012-05-23 16:48:42.028349067 +0930
+@@ -67,20 +67,29 @@
+ ACLOCAL=aclocal-1.7
+ elif (automake-1.8 --version) < /dev/null > /dev/null 2>&1; then
+ AUTOMAKE=automake-1.8
+ ACLOCAL=aclocal-1.8
+ elif (automake-1.9 --version) < /dev/null > /dev/null 2>&1; then
+ AUTOMAKE=automake-1.9
+ ACLOCAL=aclocal-1.9
+ elif (automake-1.11 --version) < /dev/null > /dev/null 2>&1; then
+ AUTOMAKE=automake-1.11
+ ACLOCAL=aclocal-1.11
++elif (automake-1.12 --version) < /dev/null > /dev/null 2>&1; then
++ AUTOMAKE=automake-1.12
++ ACLOCAL=aclocal-1.12
++elif (automake-1.13 --version) < /dev/null > /dev/null 2>&1; then
++ AUTOMAKE=automake-1.13
++ ACLOCAL=aclocal-1.13
++elif (automake-1.14 --version) < /dev/null > /dev/null 2>&1; then
++ AUTOMAKE=automake-1.14
++ ACLOCAL=aclocal-1.14
+ elif (automake-1.6 --version) < /dev/null > /dev/null 2>&1; then
+ AUTOMAKE=automake-1.6
+ ACLOCAL=aclocal-1.6
+ else
+ echo
+ echo " You must have automake 1.6 or newer installed to compile $PROJECT."
+ echo " Download the appropriate package for your distribution,"
+ echo " or get the source tarball at ftp://ftp.gnu.org/pub/gnu/automake/"
+ DIE=1
+ fi