summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Mueller2015-03-08 13:47:18 +0100
committerAaron Mueller2015-03-08 13:47:18 +0100
commit6eab7734e8e73e24889aecfe876a0e5d4aaef0df (patch)
treea8ffd3fc2b1da377efc6f490e9960573fb5bbd15
downloadaur-6eab7734e8e73e24889aecfe876a0e5d4aaef0df.tar.gz
Adopt a gimp plugin
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3eaeea7f8695
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gimp-plugin-exif-browser
+ pkgdesc = This is an Exif Viewer, mainly for jpeg photos taken with a digital camera. It is an update of the 'Exif Browser' plugin from the old registry. It requires a recent version of libexif (tested with 0.6.16).
+ pkgver = 0.1.0
+ pkgrel = 4
+ url = http://registry.gimp.org/node/8839
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libexif
+ depends = gimp>=2.4
+ source = http://registry.gimp.org/files/exif-browser.tar.gz
+ md5sums = 24902f4143445141ab0249fab9141b2a
+
+pkgname = gimp-plugin-exif-browser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91ac77af2f05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Aaron Fischer <mail@aaron-fischer.net>
+# Contributor: wanglun <iseuer@gmail.com>
+#
+pkgname=gimp-plugin-exif-browser
+pkgver=0.1.0
+pkgrel=4
+pkgdesc="This is an Exif Viewer, mainly for jpeg photos taken with a digital camera. It is an update of the 'Exif Browser' plugin from the old registry. It requires a recent version of libexif (tested with 0.6.16)."
+arch=('i686' 'x86_64')
+url="http://registry.gimp.org/node/8839"
+license=('GPL')
+depends=('gimp>=2.4')
+makedepends=('libexif')
+source=(http://registry.gimp.org/files/exif-browser.tar.gz)
+md5sums=('24902f4143445141ab0249fab9141b2a')
+
+build() {
+ cd "$srcdir/exif-browser"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/exif-browser"
+ make DESTDIR="$pkgdir/" install
+}