summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Brummer2018-01-16 13:16:37 +0100
committerBenoit Brummer2018-01-16 13:16:37 +0100
commit73ac47988013d3972f6a187e84c16a7829c9f591 (patch)
tree6600520f7ce7b31fa84e3b671b3661c26fbebabe
downloadaur-73ac47988013d3972f6a187e84c16a7829c9f591.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9baf88d2f159
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gimp-plugin-gmic-git
+ pkgdesc = QFront-end to the image processing framework G'MICQ
+ pkgver = v.218.r4.g6267a65
+ pkgrel = 1
+ url = https://github.com/c-koi/gmic-qt
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = qt5-base
+ depends = gimp
+ depends = libpng
+ depends = zlib
+ depends = fftw
+ depends = curl
+ source = git+https://github.com/c-koi/gmic-qt.git
+ source = git+https://github.com/dtschump/gmic.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = gimp-plugin-gmic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68d1152f8e18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname='gimp-plugin-gmic-git'
+_name='gmic'
+pkgver=v.218.r4.g6267a65
+pkgrel=1
+pkgdesc="QFront-end to the image processing framework G'MICQ"
+url="https://github.com/c-koi/${_name}-qt"
+makedepends=('qt5-base')
+depends=('gimp' 'libpng' 'zlib' 'fftw' 'curl')
+license=('GPL3')
+arch=('i686' 'x86_64')
+source=("git+${url}.git" "git+https://github.com/dtschump/${_name}.git")
+md5sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "${_name}-qt"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${srcdir}"
+ make -C ${_name}/src CImg.h gmic_stdlib.h
+ cd "${_name}-qt"
+ qmake HOST=gimp
+ make
+}
+
+package() {
+ cd "${srcdir}/${_name}-qt"
+ mkdir -p "${pkgdir}/usr/lib/gimp/2.0/plug-ins/"
+ cp ${_name}_gimp_qt ${pkgdir}/usr/lib/gimp/2.0/plug-ins/
+}
+