summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorApplebloom2016-01-13 20:05:22 +0100
committerApplebloom2016-01-13 20:05:22 +0100
commit8a95cea475f7ba7ad79d7e3360dfeb4ff7231b38 (patch)
tree9061903ecb872b9c25408ebe5dd4484ecbe7784a
downloadaur-8a95cea475f7ba7ad79d7e3360dfeb4ff7231b38.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec75efd500aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Jan 13 19:01:29 UTC 2016
+pkgbase = gimp-plugin-laso
+ pkgdesc = Selection tool using active contour models (aka snakes).
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://registry.gimp.org/node/25038
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = gimp
+ source = http://registry.gimp.org/files/gimp-laso-devel_3.zip
+ source = http://registry.gimp.org/files/gimp-laso-share.zip
+ md5sums = 65b59063a06234c747a6c585795ab6e6
+ md5sums = 55d39232eaa0c3a45e47cf6594adf415
+
+pkgname = gimp-plugin-laso
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..108d096cbe10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Applebloom <rat.o.drat@gmail.com>
+
+pkgname=gimp-plugin-laso
+pkgver=1.0
+pkgrel=1
+pkgdesc="Selection tool using active contour models (aka snakes)."
+arch=('i686' 'x86_64')
+url="http://registry.gimp.org/node/25038"
+license=('unknown')
+depends=('gimp')
+source=("http://registry.gimp.org/files/gimp-laso-devel_3.zip"
+ "http://registry.gimp.org/files/gimp-laso-share.zip")
+md5sums=('65b59063a06234c747a6c585795ab6e6'
+ '55d39232eaa0c3a45e47cf6594adf415')
+
+build() {
+ cd "gimp-laso-devel"
+ cc src/*.c -o "laso" `pkg-config --cflags --libs gimp-2.0` \
+ `pkg-config --cflags --libs gimpui-2.0` -lm $CFLAGS $CPPFLAGS
+}
+
+package() {
+ cd "gimp-laso-devel"
+
+ install -Dm755 "laso" "$pkgdir/usr/lib/gimp/2.0/plug-ins/laso"
+
+ for i in locale/*
+ do
+ msgfmt -o "$i/gimp20-plugin-laso.mo" "$i/gimp20-plugin-laso.po"
+ install -Dm644 "$i/gimp20-plugin-laso.po" \
+ "$pkgdir/usr/share/$i/LC_MESSAGES/gimp20-plugin-laso.mo"
+ done
+
+ cd "../GIMP-2.0"
+ find "share/gimp" -type f -exec install -Dm644 {} "$pkgdir/usr/"{} \;
+}