summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGarrett Wilson2015-08-10 19:21:59 -0500
committerGarrett Wilson2015-08-10 19:21:59 -0500
commit459a1199d566816133a3f5b943fb4c376e428784 (patch)
tree65ba43b2d14b80b8cf3ace4e8c8b51cda157be9b
downloadaur-459a1199d566816133a3f5b943fb4c376e428784.tar.gz
Initial
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e78494b2d63a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gimp-plugin-layerfx
+ pkgdesc = A GIMP plugin for layer effects (Layer->Layer Effects)
+ pkgver = 20120412
+ pkgrel = 1
+ url = http://registry.gimp.org/node/186
+ arch = any
+ license = GPLv3
+ depends = gimp
+ depends = python2
+ source = http://registry.gimp.org/files/layerfx.2.8.py.txt
+ md5sums = 408c5191552a7639f64bd6bd25891f85
+
+pkgname = gimp-plugin-layerfx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd8fcfd40313
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Garrett <floft.net/contact>
+pkgname=gimp-plugin-layerfx
+pkgver=20120412
+pkgrel=1
+pkgdesc="A GIMP plugin for layer effects (Layer->Layer Effects)"
+arch=('any')
+url='http://registry.gimp.org/node/186'
+license=('GPLv3')
+depends=('gimp' 'python2')
+source=('http://registry.gimp.org/files/layerfx.2.8.py.txt')
+md5sums=('408c5191552a7639f64bd6bd25891f85')
+
+build() {
+ sed -i "s/env python/&2/" "$srcdir/layerfx"*
+}
+
+package() {
+ dir="$pkgdir/usr/lib/gimp/2.0/plug-ins/"
+ mkdir -p "$dir"
+ cp "$srcdir/layerfx"* "$dir/layerfx.py"
+ chmod +x "$dir/layerfx.py"
+}