summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuraj Fiala2015-09-03 15:07:05 +0200
committerJuraj Fiala2015-09-03 15:07:05 +0200
commit3db6d440273a60a864b77a0e82c116234835a3d2 (patch)
treed38f365d71ba26e0113758709fd9d4606b109cbb
downloadaur-3db6d440273a60a864b77a0e82c116234835a3d2.tar.gz
Initial import.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86b7ede00c45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gimp-plugin-normalmap
+ pkgdesc = A Gimp plugin for converting images into RGB normal maps
+ pkgver = 1.2.3
+ pkgrel = 1
+ url = http://code.google.com/p/gimp-normalmap/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gimp
+ depends = gtkglext
+ depends = glew
+ conflicts = gimp-normalmap
+ replaces = gimp-normalmap
+ options = !strip
+ source = http://gimp-normalmap.googlecode.com/files/gimp-normalmap-1.2.3.tar.bz2
+ sha1sums = a7b07bae2c8c62892f8a8490d73e89367930f85e
+
+pkgname = gimp-plugin-normalmap
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d289b1057772
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Juraj Fiala <doctorjellyface at riseup dot net>
+# Contributor: kappa <kappacurve at gmail dot com>
+
+pkgname=gimp-plugin-normalmap
+_pkgname=gimp-normalmap
+pkgver=1.2.3
+pkgrel=1
+pkgdesc="A Gimp plugin for converting images into RGB normal maps"
+url="http://code.google.com/p/gimp-normalmap/"
+arch=('i686' 'x86_64')
+license=("GPL")
+depends=('gimp' 'gtkglext' 'glew')
+conflicts=('gimp-normalmap')
+replaces=('gimp-normalmap')
+source=(http://gimp-normalmap.googlecode.com/files/${_pkgname}-${pkgver}.tar.bz2)
+sha1sums=('a7b07bae2c8c62892f8a8490d73e89367930f85e')
+options=(!strip)
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make LDFLAGS=-lm
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ install -D -m 755 ./normalmap ${pkgdir}/usr/lib/gimp/2.0/plug-ins/normalmap
+}