summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaulo Fino2016-03-08 00:36:37 +0000
committerPaulo Fino2016-03-08 00:36:37 +0000
commita4d3872cc75064ede08f802c107ed7e1c8398b96 (patch)
treeb76713e9e500a1490cc3b1a0acc82247709b5920
downloadaur-a4d3872cc75064ede08f802c107ed7e1c8398b96.tar.gz
First attempt at reviving this in AUR
-rw-r--r--.SRCINFO59
-rw-r--r--PKGBUILD35
-rw-r--r--gimp-plugin-registry.install15
3 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a7510ce3d22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,59 @@
+pkgbase = gimp-plugin-registry
+ pkgdesc = Repository of optional extensions for GIMP
+ pkgver = 7.20141204
+ pkgrel = 1
+ url = https://launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp
+ install = gimp-plugin-registry.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = anaconda>=8c
+ depends = bash-completion
+ depends = desktop-file-utils
+ depends = fftw
+ depends = gcc-libs>=4.9
+ depends = gdk-pixbuf2>=2.22.0
+ depends = gimp>=2.6
+ depends = glew1.10>=1.10.0
+ depends = glib2>=2.37.3
+ depends = glibc>=2.14
+ depends = glu
+ depends = gtk2>=2.14.0
+ depends = gtkgltext
+ depends = hicolor-icon-theme
+ depends = lapack
+ depends = lcms2-git>=20110628
+ depends = libgl
+ depends = liblqr>=0.4.0
+ depends = libtiff>=4.0.3
+ depends = xdg-utils
+ optdepends = adobe-icc: ICC profiles from Adobe
+ provides = gimp-elsamuko-plugins
+ provides = gimp-fix-ca
+ provides = gimp-plugin-fblur
+ provides = gimp-plugin-layerfx
+ provides = gimp-plugin-lqr
+ provides = gimp-plugin-normalmap
+ provides = gimp-plugin-resynthesizer-git
+ provides = gimp-plugin-saveforweb
+ provides = gimp-plugin-wavelet-decompose
+ provides = gimp-plugin-wavelet-denoise
+ provides = gimp-refocus
+ conflicts = gimp-elsamuko-plugins
+ conflicts = gimp-fix-ca
+ conflicts = gimp-plugin-fblur
+ conflicts = gimp-plugin-layerfx
+ conflicts = gimp-plugin-lqr
+ conflicts = gimp-plugin-normalmap
+ conflicts = gimp-plugin-resynthesizer-git
+ conflicts = gimp-plugin-saveforweb
+ conflicts = gimp-plugin-wavelet-decompose
+ conflicts = gimp-plugin-wavelet-denoise
+ conflicts = gimp-refocus
+ replaces = gimp-refocus<0.9.0
+ source = https://launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp/+files/gimp-plugin-registry_7.20141204-0wily3~ppa_amd64.deb
+ sha256sums = c0ec1d7a154ed68d8e2e88537ed62d47154bf0e393818ad8a6d3acb8f4622428
+ source = https://launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp/+files/gimp-plugin-registry_7.20141204-0wily3~ppa_i386.deb
+ sha256sums = 38aba88c8c3a6c738aea71597e277b64162accae18e367133dd0e254ba0f6eea
+
+pkgname = gimp-plugin-registry
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce8b56c1f2db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: somepaulo <burafino@gmail.com>
+# Maintainer: Otto Meier <otto@kesselgulasch.org>
+# Original-Maintainer: Bernd Zeimetz <bzed@debian.org>
+
+pkgname=gimp-plugin-registry
+pkgver=7.20141204
+pkgrel=1
+debrel=0wily3~ppa
+debrepo=https://launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp/+files
+pkgdesc="Repository of optional extensions for GIMP"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp"
+license=('GPL')
+depends=('anaconda>=8c' 'bash-completion' 'desktop-file-utils' 'fftw' 'gcc-libs>=4.9' 'gdk-pixbuf2>=2.22.0' 'gimp>=2.6' 'glew1.10>=1.10.0' 'glib2>=2.37.3' 'glibc>=2.14' 'glu' 'gtk2>=2.14.0' 'gtkgltext' 'hicolor-icon-theme' 'lapack' 'lcms2-git>=20110628' 'libgl' 'liblqr>=0.4.0' 'libtiff>=4.0.3' 'xdg-utils')
+optdepends=('adobe-icc: ICC profiles from Adobe')
+provides=('gimp-elsamuko-plugins' 'gimp-fix-ca' 'gimp-plugin-fblur' 'gimp-plugin-layerfx' 'gimp-plugin-lqr' 'gimp-plugin-normalmap' 'gimp-plugin-resynthesizer-git' 'gimp-plugin-saveforweb' 'gimp-plugin-wavelet-decompose' 'gimp-plugin-wavelet-denoise' 'gimp-refocus')
+conflicts=('gimp-elsamuko-plugins' 'gimp-fix-ca' 'gimp-plugin-fblur' 'gimp-plugin-layerfx' 'gimp-plugin-lqr' 'gimp-plugin-normalmap' 'gimp-plugin-resynthesizer-git' 'gimp-plugin-saveforweb' 'gimp-plugin-wavelet-decompose' 'gimp-plugin-wavelet-denoise' 'gimp-refocus')
+replaces=('gimp-refocus<0.9.0')
+
+install=${pkgname}.install
+
+ if [ "$CARCH" = "x86_64" ]; then
+ _debarch=amd64
+ sha256sums=('c0ec1d7a154ed68d8e2e88537ed62d47154bf0e393818ad8a6d3acb8f4622428')
+else
+ _debarch=i386
+ sha256sums=('38aba88c8c3a6c738aea71597e277b64162accae18e367133dd0e254ba0f6eea')
+ fi
+
+source=("${debrepo}/${pkgname}_${pkgver}-${debrel}_${_debarch}.deb")
+
+package() {
+ msg2 "Installing "$pkgname"..."
+ tar xzvf data.tar.gz -C "${pkgdir}"/
+}
diff --git a/gimp-plugin-registry.install b/gimp-plugin-registry.install
new file mode 100644
index 000000000000..34b5862c518e
--- /dev/null
+++ b/gimp-plugin-registry.install
@@ -0,0 +1,15 @@
+#! /bin/bash
+
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+