summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-05-13 22:38:50 +0200
committerNarrat2015-05-13 22:38:50 +0200
commit6d2d7c2f8a6bf466be425274bc5bfb2b51b8c2bf (patch)
treef53616ba5373c1204d3af478faad8aad2e9db2e8
downloadaur-6d2d7c2f8a6bf466be425274bc5bfb2b51b8c2bf.tar.gz
resynthesizer: Latest files
History: https://github.com/Narrat/PKGBuilds
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD42
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dbd17510f0ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gimp-plugin-resynthesizer-git
+ pkgdesc = Suite of gimp plugins for texture synthesis (like heal-selection). Git-Version
+ pkgver = 2.0.r13.g251eedc
+ pkgrel = 2
+ url = https://github.com/bootchk/resynthesizer
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = intltool
+ depends = gimp
+ conflicts = gimp-resynth
+ conflicts = gimp-resynth-git
+ options = !emptydirs
+ source = git://github.com/bootchk/resynthesizer#branch=master
+ md5sums = SKIP
+
+pkgname = gimp-plugin-resynthesizer-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..eb6ec10665ae
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+*/src
+*/pkg
+*.gz
+*.xz
+*.bz2
+*.zip
+*.part
+*.sig
+*.sign
+*.txt
+*.log
+*.scm
+*/resynthesizer
+*/*.pkg
+*/*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7292b2effd28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Lex Black (autumn-wind at web.de)
+# Contributor: andre.vmatos
+
+_pkgname=resynthesizer
+pkgname=gimp-plugin-$_pkgname-git
+pkgver=2.0.r13.g251eedc
+pkgrel=2
+pkgdesc="Suite of gimp plugins for texture synthesis (like heal-selection). Git-Version"
+arch=('i686' 'x86_64')
+url="https://github.com/bootchk/resynthesizer"
+license=('GPL2')
+depends=('gimp')
+makedepends=('git' 'intltool')
+conflicts=('gimp-resynth' 'gimp-resynth-git')
+options=('!emptydirs')
+source=('git://github.com/bootchk/resynthesizer#branch=master')
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd $_pkgname
+ git describe | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+prepare() {
+ cd $_pkgname
+ sed -i 's|/usr/bin/env python|/usr/bin/env python2|' PluginScripts/*.py
+ sed -i 's/--enable-maintainer-mode//g' autogen.sh
+}
+
+build() {
+ cd $_pkgname
+
+ ./autogen.sh --disable-maintainer-mode --prefix=/usr
+ make
+}
+
+package() {
+ cd $_pkgname
+
+ make DESTDIR="$pkgdir/" install
+}