summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2015-07-30 17:00:27 +0200
committerfrederik2015-07-30 17:00:27 +0200
commit22093ac53e021148e056567ddc8e415920d8e632 (patch)
tree7ed82b1182ed08854f2eb5773e999197ff73f10e
downloadaur-22093ac53e021148e056567ddc8e415920d8e632.tar.gz
inital commit from aur3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a2abe7d2af3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gimp-plugin-separate+
+ pkgdesc = Provides some useful color-management functions for the GIMP
+ pkgver = 0.5.8
+ pkgrel = 3
+ url = http://cue.yellowmagic.info/softwares/separate-plus/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = unzip
+ depends = gimp
+ depends = lcms
+ optdepends = adobe-icc: ICC profiles from Adobe
+ optdepends = eci-icc: ICC profiles from ECI
+ replaces = gimp-plugin-separate
+ source = http://dl.sourceforge.jp/separate-plus/47873/separate+-0.5.8.zip
+ sha1sums = ca109eb5c85e91f062e747a710142888efcf85b8
+
+pkgname = gimp-plugin-separate+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0caa88138586
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Frederik Schwan <frederik dot schwan at linux dot com>
+# Contributor: foxbunny <bg.branko@gmail.com>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=gimp-plugin-separate+
+pkgver=0.5.8
+pkgrel=3
+pkgdesc='Provides some useful color-management functions for the GIMP'
+arch=('i686' 'x86_64')
+url='http://cue.yellowmagic.info/softwares/separate-plus/'
+license=('GPL2')
+depends=('gimp' 'lcms')
+makedepends=('unzip')
+optdepends=('adobe-icc: ICC profiles from Adobe'
+ 'eci-icc: ICC profiles from ECI')
+source=("http://dl.sourceforge.jp/separate-plus/47873/separate+-${pkgver}.zip")
+sha1sums=('ca109eb5c85e91f062e747a710142888efcf85b8')
+
+replaces=('gimp-plugin-separate')
+
+build() {
+ cd "${srcdir}/separate+-${pkgver}"
+ sed '/LIBS/s/$/ -lm/' -i Makefile
+ make
+}
+
+package() {
+ cd "${srcdir}/separate+-${pkgver}"
+ make PREFIX="${pkgdir}"/usr install
+
+ install -d "${pkgdir}"/usr/share/gimp/2.0/scripts
+ install -m644 sample-scripts/* "${pkgdir}"/usr/share/gimp/2.0/scripts
+}