summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-05-01 18:50:32 +0000
committerAntonio Rojas2020-05-01 18:50:32 +0000
commita5c3a54b85a00f02081031fc94b1eca805689192 (patch)
treea13e8b773e044abf79a23dc33aadfb6321f18c2b
downloadaur-gimp-plugin-wavelet-denoise.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rw-r--r--libm_buildfix.diff10
-rw-r--r--po_install.diff21
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..272410dce380
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gimp-plugin-wavelet-denoise
+ pkgdesc = Tool to reduce noise in each channel of an image separately
+ pkgver = 0.3.1
+ pkgrel = 5
+ url = https://registry.gimp.org/node/4235
+ arch = x86_64
+ license = GPL
+ depends = gimp
+ source = https://raw.githubusercontent.com/pixlsus/registry.gimp.org_static/master/registry.gimp.org/files/wavelet-denoise-0.3.1.tar.gz
+ source = po_install.diff
+ source = libm_buildfix.diff
+ md5sums = a02862026857575cdf81b24477e42f4b
+ md5sums = 4de9e41a535f200c2502f0dd8458c43e
+ md5sums = 46940ecd5970bc4b0d4b38de89f8efbf
+
+pkgname = gimp-plugin-wavelet-denoise
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91bc17cb4d0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=gimp-plugin-wavelet-denoise
+pkgver=0.3.1
+pkgrel=5
+pkgdesc="Tool to reduce noise in each channel of an image separately"
+arch=('x86_64')
+url="https://registry.gimp.org/node/4235"
+license=('GPL')
+depends=('gimp')
+source=(https://raw.githubusercontent.com/pixlsus/registry.gimp.org_static/master/registry.gimp.org/files/wavelet-denoise-$pkgver.tar.gz \
+ po_install.diff libm_buildfix.diff)
+md5sums=('a02862026857575cdf81b24477e42f4b'
+ '4de9e41a535f200c2502f0dd8458c43e'
+ '46940ecd5970bc4b0d4b38de89f8efbf')
+
+build() {
+ cd "$srcdir/wavelet-denoise-$pkgver"
+
+ patch -Np1 < ../po_install.diff || true
+ patch -Np1 < ../libm_buildfix.diff || true
+ make
+}
+
+package() {
+ cd "$srcdir/wavelet-denoise-$pkgver"
+
+ install -Dvm755 src/wavelet-denoise \
+ "$pkgdir"/usr/lib/gimp/2.0/plug-ins/wavelet-denoise
+ cd po
+ make LOCALEDIR="$pkgdir"/usr/share/locale install
+}
diff --git a/libm_buildfix.diff b/libm_buildfix.diff
new file mode 100644
index 000000000000..4a832a69b950
--- /dev/null
+++ b/libm_buildfix.diff
@@ -0,0 +1,10 @@
+diff -rup wavelet-denoise-0.3.1/src/Makefile wavelet-denoise-0.3.1.new/src/Makefile
+--- wavelet-denoise-0.3.1/src/Makefile 2008-12-14 12:19:28.000000000 +0100
++++ wavelet-denoise-0.3.1.new/src/Makefile 2012-02-18 19:01:22.264677086 +0100
+@@ -1,5 +1,5 @@
+ CFLAGS = -O3 -Wall $(shell gimptool-2.0 --cflags)
+-LIBS = $(shell gimptool-2.0 --libs)
++LIBS = -lm $(shell gimptool-2.0 --libs)
+ PLUGIN = wavelet-denoise
+ SOURCES = plugin.c colorspace.c denoise.c wavelet.c events.c interface.c
+ HEADERS = plugin.h interface.h messages.h
diff --git a/po_install.diff b/po_install.diff
new file mode 100644
index 000000000000..4b6d1a9fe247
--- /dev/null
+++ b/po_install.diff
@@ -0,0 +1,21 @@
+diff -c -r wavelet-denoise-0.3/po/Makefile wavelet-denoise-0.3-new/po/Makefile
+*** wavelet-denoise-0.3/po/Makefile 2008-12-14 12:19:22.000000000 +0100
+--- wavelet-denoise-0.3-new/po/Makefile 2008-12-20 14:57:51.000000000 +0100
+***************
+*** 24,30 ****
+
+ install: $(LANGUAGES)
+ for L in $(LANGUAGES); \
+! do install -v -m 0644 $$L.mo "$(LOCALEDIR)/$$L/LC_MESSAGES/gimp20-$(PLUGIN)-plug-in.mo"; \
+ done
+
+ uninstall: $(LANGUAGES)
+--- 24,31 ----
+
+ install: $(LANGUAGES)
+ for L in $(LANGUAGES); \
+! do mkdir -p "$(LOCALEDIR)/$$L/LC_MESSAGES"; \
+! install -v -m 0644 $$L.mo "$(LOCALEDIR)/$$L/LC_MESSAGES/gimp20-$(PLUGIN)-plug-in.mo"; \
+ done
+
+ uninstall: $(LANGUAGES)