summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mansell2015-06-28 19:24:39 -0400
committerMichael Mansell2015-06-28 19:24:39 -0400
commitf99612ddc4ae073bbc3a7123b78ea445426d737a (patch)
treee41aca8ea594fc2e6a51bd296d045343aa5e8bc0
downloadaur-f99612ddc4ae073bbc3a7123b78ea445426d737a.tar.gz
Initial Import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56a089368a68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gimp-script-divide-scanned-images
+ pkgdesc = GIMP Scheme (.scm) script for splitting separate sub-images from a composite image that has a uniform background. Creates a new image from each; will call the \'deskew\' plugin on each image (if it is installed).
+ pkgver = 2.2F
+ pkgrel = 2
+ url = https://github.com/FrancoisMalan/DivideScannedImages
+ arch = any
+ license = GPL
+ depends = gimp
+ optdepends = gimp-plugin-deskew-git: Used to straighten split images.
+ provides = gimp-script-divide-scanned-images
+ source = git://github.com/FrancoisMalan/DivideScannedImages.git
+ md5sums = SKIP
+
+pkgname = gimp-script-divide-scanned-images
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab58aa69558e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Michael Mansell <michael.mansell@gmail.com>
+
+pkgname=gimp-script-divide-scanned-images
+pkgver=2.2F
+pkgrel=2
+pkgdesc="GIMP Scheme (.scm) script for splitting separate sub-images from a composite image that has a uniform background. Creates a new image from each; will call the \'deskew\' plugin on each image (if it is installed)."
+
+arch=('any')
+url=('https://github.com/FrancoisMalan/DivideScannedImages')
+license=('GPL')
+
+depends=('gimp')
+optdepends=('gimp-plugin-deskew-git: Used to straighten split images.')
+
+source=("git://github.com/FrancoisMalan/DivideScannedImages.git")
+md5sums=('SKIP')
+
+provides=('gimp-script-divide-scanned-images')
+
+# doesn't need to build, just install
+
+package() {
+ install -Dm644 "${srcdir}/DivideScannedImages/DivideScannedImages.scm" "${pkgdir}/usr/share/gimp/2.0/scripts/DivideScannedImages.scm"
+}
+
+
+