summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Wolfer2015-07-09 11:17:18 +0200
committerPhilipp Wolfer2015-07-09 11:17:18 +0200
commitcf6b20c7fbc5210f8f95b7ffb1e6c73e11892a29 (patch)
treeb50d3a7d5db98b58dc0385a0ffe5d206ace9373c
parentc9f4ceb133816f56cabe1aa341f33bad2014555f (diff)
downloadaur-cf6b20c7fbc5210f8f95b7ffb1e6c73e11892a29.tar.gz
New upstream release 0.2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6da5fffa42b2..b8dbee235ebe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = gimp-plugin-webp
- pkgdesc = Gimp plugin to load and save files using the new WebP image format.
- pkgver = 0.1.1
- pkgrel = 2
- url = http://registry.gimp.org/node/25874
+ pkgdesc = This plugin provides Gimp with the ability to load and export WebP images.
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/nathan-osman/gimp-webp
arch = i686
arch = x86_64
license = GPL-3.0
+ makedepends = cmake
depends = gimp
depends = libwebp
- source = http://registry.gimp.org/files/gimp-webp_0.1.1.tar.gz
- sha1sums = eee1f32408e84f863de9722202b4be6a2e53a43a
+ source = https://github.com/nathan-osman/gimp-webp/archive/0.2.tar.gz
+ sha1sums = d0b0d6bbf9004a043ea10ac1fd84bd2783d190b6
pkgname = gimp-plugin-webp
diff --git a/PKGBUILD b/PKGBUILD
index a800004dfdeb..e8c55c3489b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,25 @@
# Maintainer: Philipp Wolfer <ph.wolfer@gmail.com>
pkgname=gimp-plugin-webp
-pkgver=0.1.1
-pkgrel=2
+pkgver=0.2
+pkgrel=1
pkgdesc="Gimp plugin to load and save files using the new WebP image format."
arch=('i686' 'x86_64')
-url="http://registry.gimp.org/node/25874"
+url="https://github.com/nathan-osman/gimp-webp"
license=('GPL-3.0')
depends=(gimp libwebp)
-source=(http://registry.gimp.org/files/gimp-webp_0.1.1.tar.gz)
-sha1sums=('eee1f32408e84f863de9722202b4be6a2e53a43a')
+makedepends=(cmake)
+source=(https://github.com/nathan-osman/gimp-webp/archive/$pkgver.tar.gz)
+sha1sums=('d0b0d6bbf9004a043ea10ac1fd84bd2783d190b6')
build() {
- cd "$srcdir/gimp-webp_$pkgver"
+ mkdir -p "$srcdir/gimp-webp-$pkgver/build"
+ cd "$srcdir/gimp-webp-$pkgver/build"
+ cmake ..
make
}
package() {
- cd "$srcdir/gimp-webp_$pkgver"
- make DESTDIR="$pkgdir/usr" install
+ cd "$srcdir/gimp-webp-$pkgver/build"
+ make DESTDIR="$pkgdir" install
}