summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorstevijo2016-07-21 01:06:17 +0200
committerstevijo2016-07-21 01:06:17 +0200
commit994c4ed0544a756c032ff53b92808e4699e1eec8 (patch)
tree1f5782e6491fffade1dd704c7177bc0fc96a367f
parentb6117181a135950dcd0dfa3d1fbf5422bc7c0e60 (diff)
downloadaur-994c4ed0544a756c032ff53b92808e4699e1eec8.tar.gz
upgpkg: gimx 5.8-2
-rw-r--r--.SRCINFO6
-rw-r--r--0001-arch-changes.patch42
-rw-r--r--PKGBUILD4
3 files changed, 45 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e8f843fc80c..b0b1e57890d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jul 20 22:42:59 UTC 2016
+# Wed Jul 20 23:03:45 UTC 2016
pkgbase = gimx
pkgdesc = Game Input Mulitplexer
pkgver = 5.8
- pkgrel = 1
+ pkgrel = 2
url = http://blog.gimx.fr/
arch = i686
arch = x86_64
@@ -23,7 +23,7 @@ pkgbase = gimx
source = https://github.com/matlo/GIMX/archive/v5.8.tar.gz
source = 0001-arch-changes.patch
sha256sums = bc2f035f00d49007c2221d08b2343cd0dc397e4135f6c8bc0d1418b7dc006510
- sha256sums = 1b5bd330825baea2e44367bbc59029d9cf47d68c5643b45b0631e9e16f35e3a7
+ sha256sums = d5a9153d2430f9716c35ed973694442df98195849f9bd99dc68153dd8e6815a8
pkgname = gimx
diff --git a/0001-arch-changes.patch b/0001-arch-changes.patch
index 90347872a354..b48d231d2801 100644
--- a/0001-arch-changes.patch
+++ b/0001-arch-changes.patch
@@ -1,8 +1,8 @@
diff --git a/config/Makefile b/config/Makefile
-index 6f8c759..2aa9506 100644
+index 6f8c759..af9397b 100644
--- a/config/Makefile
+++ b/config/Makefile
-@@ -8,11 +8,11 @@ endif
+@@ -8,14 +8,16 @@ endif
NAME=$(shell basename $(shell pwd))
CPPFLAGS += -I../shared/configeditor/include -I../shared/controller/include
@@ -16,6 +16,11 @@ index 6f8c759..2aa9506 100644
`curl-config --libs` \
-lxml2 \
-lstdc++ \
++ -lcrypto \
++ -lssl \
+ -lm
+ ifeq ($(OS),Windows_NT)
+ LDLIBS += -lSDL2 -lintl -liconv
diff --git a/core/display.c b/core/display.c
index b1ac9ef..b324689 100644
--- a/core/display.c
@@ -834,6 +839,39 @@ index 6f8c759..2aa9506 100644
`curl-config --libs` \
-lxml2 \
-lstdc++ \
+diff --git a/launcher/Makefile b/launcher/Makefile
+index 17d5f93..8c403a9 100644
+--- a/launcher/Makefile
++++ b/launcher/Makefile
+@@ -19,6 +19,8 @@ LDLIBS := ../shared/configeditor/configeditor.a \
+ `curl-config --libs` \
+ -lxml2 \
+ -lstdc++ \
++ -lcrypto \
++ -lssl \
+ -lm
+ ifeq ($(OS),Windows_NT)
+ LDLIBS += -lSDL2 -lintl -liconv
+diff --git a/shared/configupdater/configupdater.cpp b/shared/configupdater/configupdater.cpp
+index 0d90bb4..5677af7 100644
+--- a/shared/configupdater/configupdater.cpp
++++ b/shared/configupdater/configupdater.cpp
+@@ -11,6 +11,7 @@
+ #include <curl/curl.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <openssl/ssl.h>
+
+ #ifdef WIN32
+ #include <windows.h>
+@@ -38,6 +39,7 @@ const char * configupdater::configs_file = "configs";
+
+ configupdater::configupdater()
+ {
++ SSL_library_init();
+ curl_global_init(CURL_INIT_FLAGS);
+ }
+
diff --git a/shared/event/src/linux/timer.c b/shared/event/src/linux/timer.c
index 2967c02..8b55369 100644
--- a/shared/event/src/linux/timer.c
diff --git a/PKGBUILD b/PKGBUILD
index 7a7f0946cb9b..79fac4f7fab4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stefan Mayer <stevijo.mayer@gmail.com>
pkgname=gimx
pkgver=5.8
-pkgrel=1
+pkgrel=2
pkgdesc="Game Input Mulitplexer"
arch=('i686' 'x86_64')
url="http://blog.gimx.fr/"
@@ -11,7 +11,7 @@ makedepends=('gettext')
source=(https://github.com/matlo/GIMX/archive/v${pkgver}.tar.gz
0001-arch-changes.patch)
sha256sums=('bc2f035f00d49007c2221d08b2343cd0dc397e4135f6c8bc0d1418b7dc006510'
- '1b5bd330825baea2e44367bbc59029d9cf47d68c5643b45b0631e9e16f35e3a7')
+ '826c718a3d856f4b0af3cfdf3a28581cf3d1d2fb663d1c72f5aec9f8e889245f')
prepare() {
cd ${srcdir}/GIMX-${pkgver}