summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Penner2021-03-09 01:21:11 -0800
committerDoug Penner2021-03-09 01:21:11 -0800
commita0f6fc7b82043b18f75c16e3a6da9dc3dffb0263 (patch)
tree598d05721f2c77d1e297faaf60bc7ba3f896a41a
downloadaur-a0f6fc7b82043b18f75c16e3a6da9dc3dffb0263.tar.gz
git tag 8.0
-rw-r--r--.SRCINFO58
-rw-r--r--PKGBUILD84
-rw-r--r--ncurses.patch38
-rw-r--r--skip-bdaddr.patch13
4 files changed, 193 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc5e56d97588
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,58 @@
+pkgbase = gimx-git
+ pkgdesc = Game Input Multiplexer
+ pkgver = 8.0
+ pkgrel = 1
+ url = https://blog.gimx.fr
+ arch = any
+ license = GPLv3
+ makedepends = wxgtk2
+ makedepends = gettext
+ depends = ncurses
+ depends = xterm
+ depends = xdg-utils
+ depends = curl
+ depends = openssl
+ depends = libx11
+ depends = libxi
+ depends = mhash
+ depends = bluez-libs
+ conflicts = gimx
+ source = git+https://github.com/matlo/gimx.git#tag=v8.0
+ source = ncurses.patch
+ source = skip-bdaddr.patch
+ source = git+https://github.com/matlo/gimx-adapter-protocol.git
+ source = git+https://github.com/matlo/gimx-network-protocol.git
+ source = git+https://github.com/matlo/gimxcommon.git
+ source = git+https://github.com/matlo/gimxfile.git
+ source = git+https://github.com/matlo/gimxhid.git
+ source = git+https://github.com/matlo/gimxinput.git
+ source = git+https://github.com/matlo/gimxlog.git
+ source = git+https://github.com/matlo/gimxpoll.git
+ source = git+https://github.com/matlo/gimxprio.git
+ source = git+https://github.com/matlo/gimxserial.git
+ source = git+https://github.com/matlo/gimxtime.git
+ source = git+https://github.com/matlo/gimxtimer.git
+ source = git+https://github.com/matlo/gimxudp.git
+ source = git+https://github.com/matlo/gimxuhid.git
+ source = git+https://github.com/matlo/gimxusb.git
+ sha256sums = SKIP
+ sha256sums = 5ca4bab75b2057416da8a6a804a2a9f398cc229fee496f7a191f2e2612e11b8b
+ sha256sums = 691d672f579ecdaec55eba3d38cba5b97e016d730e555c4bcc5413def881be02
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = gimx-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a06495016b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,84 @@
+# Maintainer: Doug Penner <darwinsurvivor at gmail dot com>
+# Contributor: gimx package: Stefan Mayer <stevijo.mayer at gmail dot com>
+pkgname=gimx-git
+pkgver=8.0
+pkgrel=1
+pkgdesc='Game Input Multiplexer'
+arch=('any')
+url='https://blog.gimx.fr'
+license=('GPLv3')
+depends=('ncurses' 'xterm' 'xdg-utils' 'curl' 'openssl' 'libx11' 'libxi' 'mhash' 'bluez-libs')
+makedepends=('wxgtk2' 'gettext')
+conflicts=('gimx')
+source=('git+https://github.com/matlo/gimx.git#tag=v8.0'
+ 'ncurses.patch'
+ 'skip-bdaddr.patch'
+ 'git+https://github.com/matlo/gimx-adapter-protocol.git'
+ 'git+https://github.com/matlo/gimx-network-protocol.git'
+ 'git+https://github.com/matlo/gimxcommon.git'
+ 'git+https://github.com/matlo/gimxfile.git'
+ 'git+https://github.com/matlo/gimxhid.git'
+ 'git+https://github.com/matlo/gimxinput.git'
+ 'git+https://github.com/matlo/gimxlog.git'
+ 'git+https://github.com/matlo/gimxpoll.git'
+ 'git+https://github.com/matlo/gimxprio.git'
+ 'git+https://github.com/matlo/gimxserial.git'
+ 'git+https://github.com/matlo/gimxtime.git'
+ 'git+https://github.com/matlo/gimxtimer.git'
+ 'git+https://github.com/matlo/gimxudp.git'
+ 'git+https://github.com/matlo/gimxuhid.git'
+ 'git+https://github.com/matlo/gimxusb.git'
+)
+
+sha256sums=('SKIP'
+ '5ca4bab75b2057416da8a6a804a2a9f398cc229fee496f7a191f2e2612e11b8b'
+ '691d672f579ecdaec55eba3d38cba5b97e016d730e555c4bcc5413def881be02'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
+
+prepare() {
+ cd ${srcdir}/gimx
+ patch -p1 < ../'ncurses.patch'
+ patch -p1 < ../'skip-bdaddr.patch'
+ git submodule init
+ git config submodule.gimx-adapter-protocol.url $srcdir/gimx/shared/gimx-adapter-protocol
+ git config submodule.gimx-network-protocol.url $srcdir/gimx/shared/gimx-network-protocol
+ git config submodule.gimxcommon.url $srcdir/gimx/shared/gimxcommon
+ git config submodule.gimxfile.url $srcdir/gimx/shared/gimxfile
+ git config submodule.gimxhid.url $srcdir/gimx/shared/gimxhid
+ git config submodule.gimxinput.url $srcdir/gimx/shared/gimxinput
+ git config submodule.gimxlog.url $srcdir/gimx/shared/gimxlog
+ git config submodule.gimxpoll.url $srcdir/gimx/shared/gimxpoll
+ git config submodule.gimxprio.url $srcdir/gimx/shared/gimxprio
+ git config submodule.gimxserial.url $srcdir/gimx/shared/gimxserial
+ git config submodule.gimxtime.url $srcdir/gimx/shared/gimxtime
+ git config submodule.gimxtimer.url $srcdir/gimx/shared/gimxtimer
+ git config submodule.gimxudp.url $srcdir/gimx/shared/gimxudp
+ git config submodule.gimxuhid.url $srcdir/gimx/shared/gimxuhid
+ git config gimxusb.url $srcdir/gimx/shared/gimxusb
+ git submodule update
+}
+
+build() {
+ cd ${srcdir}/gimx
+ make
+}
+
+package() {
+ cd ${srcdir}/gimx
+ make install DESTDIR=${pkgdir}
+}
diff --git a/ncurses.patch b/ncurses.patch
new file mode 100644
index 000000000000..a69ebab20446
--- /dev/null
+++ b/ncurses.patch
@@ -0,0 +1,38 @@
+diff --git a/core/Makefile b/core/Makefile
+index e058d3ef..8bbd2f86 100644
+--- a/core/Makefile
++++ b/core/Makefile
+@@ -42,13 +42,8 @@ CPPFLAGS += `xml2-config --cflags`
+ LDLIBS += `xml2-config --libs`
+
+ ifneq ($(PDCURSES),1)
+-ifneq ($(OS),Windows_NT)
+-CPPFLAGS += `ncursesw5-config --cflags`
+-LDLIBS += `ncursesw5-config --libs`
+-else
+ CPPFLAGS += `ncursesw6-config --cflags`
+ LDLIBS += `ncursesw6-config --libs`
+-endif
+ else
+ CFLAGS += -DPDCURSES
+ LDLIBS += -lpdcursesw
+@@ -106,4 +101,4 @@ uninstall:
+ -rmdir $(prefix)
+
+ really-clean: clean uninstall
+-endif
+\ No newline at end of file
++endif
+diff --git a/core/display.c b/core/display.c
+index 575b29e9..f8fee3b8 100644
+--- a/core/display.c
++++ b/core/display.c
+@@ -8,7 +8,7 @@
+ #ifdef PDCURSES
+ #include <cursesw.h>
+ #else
+-#include <ncursesw/ncurses.h>
++#include <ncurses.h>
+ #endif
+
+ #include "display.h"
diff --git a/skip-bdaddr.patch b/skip-bdaddr.patch
new file mode 100644
index 000000000000..b05a289a39bb
--- /dev/null
+++ b/skip-bdaddr.patch
@@ -0,0 +1,13 @@
+diff --git a/utils/Makefile b/utils/Makefile
+index 5d2a9ab0..a6fc47c0 100644
+--- a/utils/Makefile
++++ b/utils/Makefile
+@@ -7,7 +7,7 @@ endif
+
+ BINS=
+ ifneq ($(OS),Windows_NT)
+-BINS+=ds4tool sixaddr bdaddr hcirevision
++BINS+=ds4tool sixaddr hcirevision
+ OUT=$(BINS)
+ else
+ OUT=ds4tool.exe sixaddr.exe