summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Soares2016-06-22 13:51:07 -0400
committerRafael Soares2016-06-22 13:51:07 -0400
commit945613a8d911d1c8b50d7c1f1e68769ca58f8ff5 (patch)
tree90c7863c930e4fb3a56d9637a38a659347dce7a8
downloadaur-945613a8d911d1c8b50d7c1f1e68769ca58f8ff5.tar.gz
First commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitlab-ci.yml12
-rw-r--r--CONTRIBUTING.md14
-rw-r--r--PKGBUILD71
-rw-r--r--README.md8
5 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7b14c99ad19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Tue Jun 21 00:26:15 UTC 2016
+pkgbase = ginger-base
+ pkgdesc = Basic host management for WoK
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = http://kimchi-project.github.io/gingerbase/
+ arch = any
+ groups = kimchi-project
+ license = AGPL2.1
+ license = Apache
+ makedepends = git
+ depends = python2-configobj
+ depends = python2-pyparted
+ depends = wok
+ provides = ginger-base
+ conflicts = ginger-base-git
+ backup = etc/wok/plugins.d/gingerbase.conf
+ source = https://github.com/kimchi-project/gingerbase/archive/2.1.0.tar.gz
+ sha256sums = 1b9b02dc64187cfff5fc0a7a548087da197a1b2193ce408f1354e9666695e937
+
+pkgname = ginger-base
+
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 000000000000..4710928feae7
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,12 @@
+stages:
+ - build
+ - test
+ - deploy
+
+job_makepkg:
+ stage: build
+ script:
+ - makepkg -srf --noconfirm --noprogressbar
+ tags:
+ - arch
+ - shell
diff --git a/CONTRIBUTING.md b/CONTRIBUTING.md
new file mode 100644
index 000000000000..57743cb44d2d
--- /dev/null
+++ b/CONTRIBUTING.md
@@ -0,0 +1,14 @@
+How to contribute:
+
+
+0 - Sign in to https://github.com
+
+1 - Go to https://github.com/rafaelsoaresbr/ginger-base
+
+2 - Submit a new Issue and/or:
+
+3 - Fork this project
+
+4 - Commit your change
+
+5 - Submit a new pull request
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93ac51a00c4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer=rafaelsoaresbr <rafaelsoaresbr@gmail.com>
+# ginger-base
+# Contributing: https://github.com/rafaelsoaresbr/ginger-base.git
+# Builds: https://gitlab.com/rafaelsoaresbr/ginger-base/builds
+#pkgbase=()
+pkgname=('ginger-base')
+
+# Version
+pkgver=2.1.0
+pkgrel=1
+#epoch=
+
+# Generic
+pkgdesc="Basic host management for WoK"
+arch=('any')
+url="http://kimchi-project.github.io/gingerbase/"
+license=('AGPL2.1' 'Apache')
+groups=('kimchi-project')
+
+# Dependencies
+depends=('python2-configobj'
+ 'python2-pyparted'
+ 'wok')
+#optdepends=()
+makedepends=('git')
+#checkdepends=()
+
+# Package Relations
+provides=('ginger-base')
+conflicts=('ginger-base-git')
+#replaces=()
+
+# Others
+backup=('etc/wok/plugins.d/gingerbase.conf')
+#options=()
+#install=
+#changelog=
+
+# Sources
+source=('https://github.com/kimchi-project/gingerbase/archive/'${pkgver}'.tar.gz')
+#source_i686=("")
+#source_x86_64=("")
+#noextract=()
+#validpgpkeys=()
+
+# Integrity
+#md5sums=()
+#md5sums_i686=()
+#md5sums_x86_64=()
+#sha1sums=()
+sha256sums=('1b9b02dc64187cfff5fc0a7a548087da197a1b2193ce408f1354e9666695e937')
+
+#pkgver() {
+#}
+
+prepare() {
+ cd $srcdir/gingerbase-${pkgver}
+}
+
+build() {
+ cd $srcdir/gingerbase-${pkgver}
+ PYTHON=/usr/bin/python2 ./autogen.sh --system && make
+}
+
+#check() {
+#}
+
+package() {
+ cd $srcdir/gingerbase-${pkgver}
+ make DESTDIR=$pkgdir install
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..db1430853f7f
--- /dev/null
+++ b/README.md
@@ -0,0 +1,8 @@
+AUR Package:
+
+
+ginger-base
+
+Contributing: https://github.com/rafaelsoaresbr/ginger-base.git
+
+Builds: https://gitlab.com/rafaelsoaresbr/ginger-base/builds