summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Kerrick2021-07-15 14:11:11 -0400
committerEthan Kerrick2021-07-15 14:11:11 -0400
commit36e13853437162bc276d17a25522ab9d5b41fc6a (patch)
tree6bd1888d7c3e413b542820954939e5f05c6b7eba
downloadaur-36e13853437162bc276d17a25522ab9d5b41fc6a.tar.gz
inital creation of package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3aae01ea510
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gingerblue
+ pkgdesc = for musicians who compose, record, and share original music
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://www.gingerblue.org/
+ arch = x86_64
+ license = GPL
+ makedepends = libchamplain
+ makedepends = geocode-glib
+ depends = intltool
+ depends = gst-plugins-bad
+ depends = libshout
+ depends = gtk3
+ provides = gingerblue
+ source = https://www.gingerblue.org/src/gingerblue-1.0.0.tar.xz
+ sha256sums = 6ca6ea29d0ecae86981e9749e2a969143275f68ab676b21ebcd75ffd8248ce44
+
+pkgname = gingerblue
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82cb39237ec0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: silverhikari
+pkgname=gingerblue
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="for musicians who compose, record, and share original music"
+arch=("x86_64")
+url="https://www.gingerblue.org/"
+license=("GPL")
+depends=("intltool" "gst-plugins-bad" "libshout" "gtk3")
+makedepends=("libchamplain" "geocode-glib")
+provides=("gingerblue")
+source=("https://www.gingerblue.org/src/${pkgname}-${pkgver}.tar.xz")
+sha256sums=("6ca6ea29d0ecae86981e9749e2a969143275f68ab676b21ebcd75ffd8248ce44")
+
+build() {
+ cd "$pkgname-$pkgver"
+ autoreconf
+ aclocal
+ automake --add-missing
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}