summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Price2018-06-01 21:24:34 +0100
committerWill Price2018-06-01 21:24:34 +0100
commit65934f09f5b9f4bc7507223bf261b83e412d29ac (patch)
tree328743db0e224ac0094f08465d8a00163cf1e30d
downloadaur-65934f09f5b9f4bc7507223bf261b83e412d29ac.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD43
-rw-r--r--gingko.desktop10
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1364bee981e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Jun 1 20:24:29 UTC 2018
+pkgbase = gingko
+ pkgdesc = Manage all your JetBrains Projects and Tools
+ pkgver = 2.0.11
+ pkgrel = 1
+ url = https://gingko.io/
+ arch = x86_64
+ arch = i686
+ license = Commercial
+ options = !strip
+ source = https://github.com/gingko/client/releases/download/v2.0.11/gingko-client-2.0.11-x86_64.AppImage
+ source = gingko.desktop
+ sha512sums = e3f9508579892d1c71f34b132c5f66990d8b2660c081e9dbd61f5ec3e5919ea9f248451b3bf8d7764273522b3a22682907f7cb88ea73aab8866be03bb8dfe778
+ sha512sums = c11e9c2541211d0ff43d4ff26fd23f6c64d8bb8008bddbbe174a420a69cc981120c3c5466e47894515fee0dbaccd95309eb61a16ffc3b3193af0609e62b46820
+
+pkgname = gingko
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2cf4b999d079
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/pkg/
+/src/
+/*.tar.gz
+/*.pkg.*
+*.AppImage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4daad57ba65c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Will Price <will.price94@gmail.com>
+
+# Inspired by https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=jetbrains-toolbox
+# and https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=hyper-appimage
+
+pkgname=gingko
+pkgver=2.0.11
+pkgrel=1
+pkgdesc='Manage all your JetBrains Projects and Tools'
+arch=('x86_64' 'i686')
+url='https://gingko.io/'
+license=('Commercial')
+depends=()
+options=('!strip')
+source=("https://github.com/gingko/client/releases/download/v${pkgver}/gingko-client-${pkgver}-x86_64.AppImage"
+ "gingko.desktop")
+sha512sums=('e3f9508579892d1c71f34b132c5f66990d8b2660c081e9dbd61f5ec3e5919ea9f248451b3bf8d7764273522b3a22682907f7cb88ea73aab8866be03bb8dfe778'
+ 'c11e9c2541211d0ff43d4ff26fd23f6c64d8bb8008bddbbe174a420a69cc981120c3c5466e47894515fee0dbaccd95309eb61a16ffc3b3193af0609e62b46820')
+
+prepare() {
+ chmod +x "${srcdir}/gingko-client-${pkgver}-x86_64.AppImage"
+ "${srcdir}/gingko-client-${pkgver}-x86_64.AppImage" --appimage-extract
+}
+
+package() {
+ install -d -m 755 "${pkgdir}/usr/bin/"
+ install -d -m 755 "${pkgdir}/opt/${pkgname}"
+ cp -Rr "${srcdir}/squashfs-root/app/"* "${pkgdir}/opt/${pkgname}"
+
+ install -d -m755 "${pkgdir}/usr/share/icons/hicolor"
+ cp -Rr "${srcdir}/squashfs-root/usr/share/icons/hicolor/" \
+ "${pkgdir}/usr/share/icons/"
+
+ install -D -m 644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ ln -s "/opt/${pkgname}/gingko-client" "${pkgdir}/usr/bin/${pkgname}"
+
+ # fix file permissions - all files as 644 - directories as 755
+ # by default directories come out as 700
+ find "${pkgdir}/"{opt,usr} -type d -exec chmod 755 {} \;
+ find "${pkgdir}/"{opt,usr} -type f -exec chmod 644 {} \;
+ chmod +x "${pkgdir}/opt/${pkgname}/gingko-client"
+}
diff --git a/gingko.desktop b/gingko.desktop
new file mode 100644
index 000000000000..d14c18a430b5
--- /dev/null
+++ b/gingko.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Gingko
+Icon=/usr/share/icons/hicolor/512x512/gingko-client.png
+Exec="/opt/gingko/gingko-client"
+Comment=Gingko lets you untangle your thoughts as your write them.
+Categories=Office;WordProcessor;
+Terminal=false
+StartupWMClass=gingko