summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu2015-06-19 12:02:49 +1000
committerJonathan Liu2015-06-19 12:02:49 +1000
commit89bc226fd0d33d17dfc72ad2fd1c3131295f50a6 (patch)
treede206723a9b622e61d724284ca03f3258e60ceb7
downloadaur-89bc226fd0d33d17dfc72ad2fd1c3131295f50a6.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD50
-rw-r--r--ginkgo-cadx.install13
-rw-r--r--ginkgocadx.desktop11
-rw-r--r--ginkgocadx.pngbin0 -> 50788 bytes
-rw-r--r--itk-4.0.patch255
-rw-r--r--translations.patch18
-rw-r--r--vtk-5.10.patch279
8 files changed, 657 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b3fe01c2bda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = ginkgo-cadx-2
+ pkgdesc = Complete DICOM viewer solution
+ pkgver = 2.14.0.4972
+ pkgrel = 2
+ url = http://ginkgo-cadx.com/
+ install = ginkgo-cadx.install
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ depends = dcmtk
+ depends = insight-toolkit
+ depends = tcp_wrappers
+ depends = vtk
+ depends = wxgtk2.8
+ conflicts = ginkgo-cadx
+ options = !strip
+ source = http://downloads.sourceforge.net/project/ginkgocadx/2.14.0/ginkgocadx-2.14.0.4972.tgz
+ source = itk-4.0.patch
+ source = vtk-5.10.patch
+ source = translations.patch
+ source = ginkgocadx.desktop
+ source = ginkgocadx.png
+ md5sums = a52f7d2319195224e675b6e1af088947
+ md5sums = 0cc4bacb5b1378e2865669887688e06f
+ md5sums = 9e9bccebcd37bf9ae7aaa8198a4c1266
+ md5sums = 7085e99c2689c3e70317e8af23599cb4
+ md5sums = 16998d859432ab9348a9e835d0135a98
+ md5sums = 1de087126d5e72ecdacc2e215601827f
+
+pkgname = ginkgo-cadx-2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c931e4812b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Jonathan Liu <net147@gmail.com>
+pkgname=ginkgo-cadx-2
+_realpkgname=ginkgo-cadx
+pkgver=2.14.0.4972
+pkgrel=2
+pkgdesc="Complete DICOM viewer solution"
+arch=('i686' 'x86_64')
+url="http://ginkgo-cadx.com/"
+license=('LGPL3')
+makdepends=('cmake')
+depends=('dcmtk' 'insight-toolkit' 'tcp_wrappers' 'vtk' 'wxgtk2.8')
+conflicts=('ginkgo-cadx')
+install="${_realpkgname}.install"
+options=('!strip')
+source=("http://downloads.sourceforge.net/project/ginkgocadx/${pkgver%.*}/${_realpkgname/-/}-${pkgver}.tgz"
+ "itk-4.0.patch"
+ "vtk-5.10.patch"
+ "translations.patch"
+ "ginkgocadx.desktop"
+ "ginkgocadx.png")
+md5sums=('a52f7d2319195224e675b6e1af088947'
+ '0cc4bacb5b1378e2865669887688e06f'
+ '9e9bccebcd37bf9ae7aaa8198a4c1266'
+ '7085e99c2689c3e70317e8af23599cb4'
+ '16998d859432ab9348a9e835d0135a98'
+ '1de087126d5e72ecdacc2e215601827f')
+
+prepare() {
+ [ -d build ] || mkdir build
+ cd "${srcdir}/${_realpkgname/-/}-${pkgver}"
+ patch -Np1 -i "${srcdir}/itk-4.0.patch"
+ patch -Np1 -i "${srcdir}/vtk-5.10.patch"
+ patch -Np1 -i "${srcdir}/translations.patch"
+}
+
+build() {
+ cd build
+ LDFLAGS=-L/usr/lib/dcmtk cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_LIBRARY_PATH=/usr/lib/dcmtk -DVTK_DIR=/usr \
+ -DwxWidgets_CONFIG_EXECUTABLE="/usr/bin/wx-config-2.8" -DwxWidgets_wxrc_EXECUTABLE="/usr/bin/wxrc-2.8" "../${_realpkgname/-/}-${pkgver}"
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 "${srcdir}/ginkgocadx.desktop" "${pkgdir}/usr/share/applications/ginkgocadx.desktop"
+ install -D -m644 "${srcdir}/ginkgocadx.png" "${pkgdir}/usr/share/pixmaps/ginkgocadx.png"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ginkgo-cadx.install b/ginkgo-cadx.install
new file mode 100644
index 000000000000..0919e90789c2
--- /dev/null
+++ b/ginkgo-cadx.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+post_remove() {
+ post_install "$1"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ginkgocadx.desktop b/ginkgocadx.desktop
new file mode 100644
index 000000000000..2c990ce65f08
--- /dev/null
+++ b/ginkgocadx.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Ginkgo CADx
+GenericName=DICOM viewer
+Comment=Complete DICOM viewer solution
+Exec=ginkgocadx
+Icon=ginkgocadx
+Terminal=false
+Type=Application
+Categories=Graphics;3DGraphics;Viewer;
+X-KDE-StartupNotify=true
diff --git a/ginkgocadx.png b/ginkgocadx.png
new file mode 100644
index 000000000000..b5fc08509957
--- /dev/null
+++ b/ginkgocadx.png
Binary files differ
diff --git a/itk-4.0.patch b/itk-4.0.patch
new file mode 100644
index 000000000000..436661132140
--- /dev/null
+++ b/itk-4.0.patch
@@ -0,0 +1,255 @@
+diff -Nur ginkgocadx-2.8.0.4602.orig/src/cadxcore/commands/comandoexportacion.cpp ginkgocadx-2.8.0.4602/src/cadxcore/commands/comandoexportacion.cpp
+--- ginkgocadx-2.8.0.4602.orig/src/cadxcore/commands/comandoexportacion.cpp 2012-01-26 19:12:04.000000000 +1100
++++ ginkgocadx-2.8.0.4602/src/cadxcore/commands/comandoexportacion.cpp 2012-02-11 20:19:47.017270784 +1100
+@@ -36,7 +36,6 @@
+
+ #include <itkExceptionObject.h>
+ #include <itkImage.h>
+-#include <itkOrientedImage.h>
+ #include <itkRGBPixel.h>
+ #include <itkGDCMImageIO.h>
+ #include <itkJPEGImageIO.h>
+diff -Nur ginkgocadx-2.8.0.4602.orig/src/cadxcore/commands/comandogenerarthumbnails.cpp ginkgocadx-2.8.0.4602/src/cadxcore/commands/comandogenerarthumbnails.cpp
+--- ginkgocadx-2.8.0.4602.orig/src/cadxcore/commands/comandogenerarthumbnails.cpp 2012-01-26 19:12:04.000000000 +1100
++++ ginkgocadx-2.8.0.4602/src/cadxcore/commands/comandogenerarthumbnails.cpp 2012-02-11 20:19:37.683789667 +1100
+@@ -49,7 +49,6 @@
+
+ #include <itkExceptionObject.h>
+ #include <itkImage.h>
+-#include <itkOrientedImage.h>
+ #include <itkRGBPixel.h>
+ #include <itkGDCMImageIO.h>
+ #include <itkImageFileReader.h>
+diff -Nur ginkgocadx-2.8.0.4602.orig/src/cadxcore/main/controllers/streaming/streamingloader.cpp ginkgocadx-2.8.0.4602/src/cadxcore/main/controllers/streaming/streamingloader.cpp
+--- ginkgocadx-2.8.0.4602.orig/src/cadxcore/main/controllers/streaming/streamingloader.cpp 2012-01-26 19:12:04.000000000 +1100
++++ ginkgocadx-2.8.0.4602/src/cadxcore/main/controllers/streaming/streamingloader.cpp 2012-02-11 20:19:24.886929338 +1100
+@@ -46,7 +46,6 @@
+ #include <vtkImageDataStreamer.h>
+
+ #include <itkImage.h>
+-#include <itkOrientedImage.h>
+ #include <itkCommand.h>
+ #include <itkMetaDataObject.h>
+
+@@ -272,7 +271,7 @@
+ case ImageIO::UCHAR:
+ {
+ typedef unsigned char TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -282,7 +281,7 @@
+ case ImageIO::CHAR:
+ {
+ typedef char TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -292,7 +291,7 @@
+ case ImageIO::USHORT:
+ {
+ typedef unsigned short TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -302,7 +301,7 @@
+ case ImageIO::SHORT:
+ {
+ typedef short TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -312,7 +311,7 @@
+ case ImageIO::UINT:
+ {
+ typedef unsigned int TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -322,7 +321,7 @@
+ case ImageIO::INT:
+ {
+ typedef int TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -332,7 +331,7 @@
+ case ImageIO::ULONG:
+ {
+ typedef unsigned long TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -342,7 +341,7 @@
+ case ImageIO::LONG:
+ {
+ typedef long TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -352,7 +351,7 @@
+ case ImageIO::FLOAT:
+ {
+ typedef float TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -361,7 +360,7 @@
+ case ImageIO::DOUBLE:
+ {
+ typedef double TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -383,7 +382,7 @@
+ {
+ typedef unsigned char TypedComponentType;
+ typedef itk::RGBPixel<TypedComponentType> TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -394,7 +393,7 @@
+ {
+ typedef char TypedComponentType;
+ typedef itk::RGBPixel<TypedComponentType> TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -405,7 +404,7 @@
+ {
+ typedef unsigned short TypedComponentType;
+ typedef itk::RGBPixel<TypedComponentType> TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -416,7 +415,7 @@
+ {
+ typedef short TypedComponentType;
+ typedef itk::RGBPixel<TypedComponentType> TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -427,7 +426,7 @@
+ {
+ typedef unsigned int TypedComponentType;
+ typedef itk::RGBPixel<TypedComponentType> TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -438,7 +437,7 @@
+ {
+ typedef int TypedComponentType;
+ typedef itk::RGBPixel<TypedComponentType> TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -449,7 +448,7 @@
+ {
+ typedef long TypedComponentType;
+ typedef itk::RGBPixel<TypedComponentType> TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -460,7 +459,7 @@
+ {
+ typedef unsigned long TypedComponentType;
+ typedef itk::RGBPixel<TypedComponentType> TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -471,7 +470,7 @@
+ {
+ typedef float TypedComponentType;
+ typedef itk::RGBPixel<TypedComponentType> TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -482,7 +481,7 @@
+ {
+ typedef double TypedComponentType;
+ typedef itk::RGBPixel<TypedComponentType> TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageFileReader<TypedImageType> TypedReaderType;
+ TypedReaderType* pTypedReader = static_cast<TypedReaderType*>(m_pReader.GetPointer());
+ pTypedReader->SetFileName(fichero);
+@@ -646,7 +645,7 @@
+ m_pOutput->RemoveAllInputs();
+
+ typedef unsigned short TypedPixelType;
+- typedef itk::OrientedImage<TypedPixelType, 3 > TypedImageType;
++ typedef itk::Image<TypedPixelType, 3 > TypedImageType;
+ typedef itk::ImageToVTKImageFilter<TypedImageType> TypedJoinerType;
+
+ TypedImageType::Pointer img = TypedImageType::New();
+diff -Nur ginkgocadx-2.8.0.4602.orig/src/cadxcore/stdafx.h ginkgocadx-2.8.0.4602/src/cadxcore/stdafx.h
+--- ginkgocadx-2.8.0.4602.orig/src/cadxcore/stdafx.h 2012-01-26 19:12:05.000000000 +1100
++++ ginkgocadx-2.8.0.4602/src/cadxcore/stdafx.h 2012-02-11 20:18:55.606475488 +1100
+@@ -69,7 +69,6 @@
+ #include <itkThresholdImageFilter.h>
+
+ #include <itkImage.h>
+- #include <itkOrientedImage.h>
+ #include <itkRGBPixel.h>
+ #include <itkScalarImageToHistogramGenerator.h>
+ #include <itkBinaryThresholdImageFilter.h>
+diff -Nur ginkgocadx-2.8.0.4602.orig/src/lightvisualizator/lightvisustdafx.h ginkgocadx-2.8.0.4602/src/lightvisualizator/lightvisustdafx.h
+--- ginkgocadx-2.8.0.4602.orig/src/lightvisualizator/lightvisustdafx.h 2012-01-26 19:08:42.000000000 +1100
++++ ginkgocadx-2.8.0.4602/src/lightvisualizator/lightvisustdafx.h 2012-02-11 20:18:45.342984445 +1100
+@@ -69,7 +69,6 @@
+ #include <itkThresholdImageFilter.h>
+
+ #include <itkImage.h>
+- #include <itkOrientedImage.h>
+ #include <itkRGBPixel.h>
+ #include <itkScalarImageToHistogramGenerator.h>
+ #include <itkBinaryThresholdImageFilter.h>
+diff -Nur ginkgocadx-2.8.0.4602.orig/src/visualizator/visustdafx.h ginkgocadx-2.8.0.4602/src/visualizator/visustdafx.h
+--- ginkgocadx-2.8.0.4602.orig/src/visualizator/visustdafx.h 2012-01-26 19:08:44.000000000 +1100
++++ ginkgocadx-2.8.0.4602/src/visualizator/visustdafx.h 2012-02-11 20:18:35.549498434 +1100
+@@ -69,7 +69,6 @@
+ #include <itkThresholdImageFilter.h>
+
+ #include <itkImage.h>
+- #include <itkOrientedImage.h>
+ #include <itkRGBPixel.h>
+ #include <itkScalarImageToHistogramGenerator.h>
+ #include <itkBinaryThresholdImageFilter.h>
diff --git a/translations.patch b/translations.patch
new file mode 100644
index 000000000000..c638df57a9f8
--- /dev/null
+++ b/translations.patch
@@ -0,0 +1,18 @@
+diff -Nur ginkgocadx-2.14.0.4972.orig/src/cadxcore/CMakeLists.txt ginkgocadx-2.14.0.4972/src/cadxcore/CMakeLists.txt
+--- ginkgocadx-2.14.0.4972.orig/src/cadxcore/CMakeLists.txt 2012-06-26 21:56:21.000000000 +1000
++++ ginkgocadx-2.14.0.4972/src/cadxcore/CMakeLists.txt 2012-06-30 20:07:59.080117964 +1000
+@@ -209,10 +209,10 @@
+ LINK_INTERFACE_LIBRARIES ""
+ INSTALL_RPATH_USE_LINK_PATH FALSE )
+ INSTALL(TARGETS ${PROJECT_NAME} LIBRARY DESTINATION lib/ginkgocadx)
+-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/lang/es/ginkgocadxcore.mo DESTINATION share/ginkgocadx/lang/es)
+-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/lang/ja/ginkgocadxcore.mo DESTINATION share/ginkgocadx/lang/ja)
+-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/lang/de/ginkgocadxcore.mo DESTINATION share/ginkgocadx/lang/de)
+-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/lang/tr/ginkgocadxcore.mo DESTINATION share/ginkgocadx/lang/tr)
++INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/lang/es/cadxcore.mo DESTINATION share/ginkgocadx/lang/es)
++INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/lang/ja/cadxcore.mo DESTINATION share/ginkgocadx/lang/ja)
++INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/lang/de/cadxcore.mo DESTINATION share/ginkgocadx/lang/de)
++INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/lang/tr/cadxcore.mo DESTINATION share/ginkgocadx/lang/tr)
+ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/resources/conformance.xml DESTINATION share/ginkgocadx)
+ ################ LIBS ################
+
diff --git a/vtk-5.10.patch b/vtk-5.10.patch
new file mode 100644
index 000000000000..badabeb3749a
--- /dev/null
+++ b/vtk-5.10.patch
@@ -0,0 +1,279 @@
+diff -Nur ginkgocadx-2.14.0.4972.orig/src/cadxcore/cadxcore.vcproj ginkgocadx-2.14.0.4972/src/cadxcore/cadxcore.vcproj
+--- ginkgocadx-2.14.0.4972.orig/src/cadxcore/cadxcore.vcproj 2012-06-26 21:57:36.000000000 +1000
++++ ginkgocadx-2.14.0.4972/src/cadxcore/cadxcore.vcproj 2012-06-30 21:40:28.122990260 +1000
+@@ -1718,14 +1718,6 @@
+ Name="vtk"
+ >
+ <File
+- RelativePath=".\vtk\hackimageactor.cpp"
+- >
+- </File>
+- <File
+- RelativePath=".\vtk\hackimageactor.h"
+- >
+- </File>
+- <File
+ RelativePath=".\vtk\vtkginkgoimageviewer.cpp"
+ >
+ </File>
+diff -Nur ginkgocadx-2.14.0.4972.orig/src/cadxcore/cadxcore.xcodeproj/project.pbxproj ginkgocadx-2.14.0.4972/src/cadxcore/cadxcore.xcodeproj/project.pbxproj
+--- ginkgocadx-2.14.0.4972.orig/src/cadxcore/cadxcore.xcodeproj/project.pbxproj 2012-06-26 21:56:19.000000000 +1000
++++ ginkgocadx-2.14.0.4972/src/cadxcore/cadxcore.xcodeproj/project.pbxproj 2012-06-30 21:40:48.223299698 +1000
+@@ -23,7 +23,6 @@
+ 073FA0241331160800CC2CDB /* sqlite3.c in Sources */ = {isa = PBXBuildFile; fileRef = 073F9DF0133115CB00CC2CDB /* sqlite3.c */; };
+ 073FA0251331160800CC2CDB /* stdafx.cpp in Sources */ = {isa = PBXBuildFile; fileRef = 073F9DF3133115CB00CC2CDB /* stdafx.cpp */; };
+ 073FA0261331160800CC2CDB /* ginkgoimagecommand.cpp in Sources */ = {isa = PBXBuildFile; fileRef = 073F9DF7133115CB00CC2CDB /* ginkgoimagecommand.cpp */; };
+- 073FA0271331160800CC2CDB /* hackimageactor.cpp in Sources */ = {isa = PBXBuildFile; fileRef = 073F9DF9133115CB00CC2CDB /* hackimageactor.cpp */; };
+ 073FA0281331160800CC2CDB /* ginkgointeractorstyleimage2d.cpp in Sources */ = {isa = PBXBuildFile; fileRef = 073F9DFC133115CB00CC2CDB /* ginkgointeractorstyleimage2d.cpp */; };
+ 073FA0291331160800CC2CDB /* vtkginkgoimageviewer.cpp in Sources */ = {isa = PBXBuildFile; fileRef = 073F9DFE133115CB00CC2CDB /* vtkginkgoimageviewer.cpp */; };
+ 073FA02A1331160800CC2CDB /* vtkopenglginkgotexture.cpp in Sources */ = {isa = PBXBuildFile; fileRef = 073F9E00133115CB00CC2CDB /* vtkopenglginkgotexture.cpp */; };
+@@ -437,8 +436,6 @@
+ 073F9DF4133115CB00CC2CDB /* stdafx.h */ = {isa = PBXFileReference; fileEncoding = 4; lastKnownFileType = sourcecode.c.h; path = stdafx.h; sourceTree = "<group>"; };
+ 073F9DF7133115CB00CC2CDB /* ginkgoimagecommand.cpp */ = {isa = PBXFileReference; fileEncoding = 4; lastKnownFileType = sourcecode.cpp.cpp; path = ginkgoimagecommand.cpp; sourceTree = "<group>"; };
+ 073F9DF8133115CB00CC2CDB /* ginkgoimagecommand.h */ = {isa = PBXFileReference; fileEncoding = 4; lastKnownFileType = sourcecode.c.h; path = ginkgoimagecommand.h; sourceTree = "<group>"; };
+- 073F9DF9133115CB00CC2CDB /* hackimageactor.cpp */ = {isa = PBXFileReference; fileEncoding = 4; lastKnownFileType = sourcecode.cpp.cpp; path = hackimageactor.cpp; sourceTree = "<group>"; };
+- 073F9DFA133115CB00CC2CDB /* hackimageactor.h */ = {isa = PBXFileReference; fileEncoding = 4; lastKnownFileType = sourcecode.c.h; path = hackimageactor.h; sourceTree = "<group>"; };
+ 073F9DFC133115CB00CC2CDB /* ginkgointeractorstyleimage2d.cpp */ = {isa = PBXFileReference; fileEncoding = 4; lastKnownFileType = sourcecode.cpp.cpp; path = ginkgointeractorstyleimage2d.cpp; sourceTree = "<group>"; };
+ 073F9DFD133115CB00CC2CDB /* ginkgointeractorstyleimage2d.h */ = {isa = PBXFileReference; fileEncoding = 4; lastKnownFileType = sourcecode.c.h; path = ginkgointeractorstyleimage2d.h; sourceTree = "<group>"; };
+ 073F9DFE133115CB00CC2CDB /* vtkginkgoimageviewer.cpp */ = {isa = PBXFileReference; fileEncoding = 4; lastKnownFileType = sourcecode.cpp.cpp; path = vtkginkgoimageviewer.cpp; sourceTree = "<group>"; };
+@@ -1451,8 +1448,6 @@
+ isa = PBXGroup;
+ children = (
+ 073F9DF6133115CB00CC2CDB /* command */,
+- 073F9DF9133115CB00CC2CDB /* hackimageactor.cpp */,
+- 073F9DFA133115CB00CC2CDB /* hackimageactor.h */,
+ 073F9DFB133115CB00CC2CDB /* interactor */,
+ 073F9DFE133115CB00CC2CDB /* vtkginkgoimageviewer.cpp */,
+ 073F9DFF133115CB00CC2CDB /* vtkginkgoimageviewer.h */,
+@@ -2577,7 +2572,6 @@
+ 073FA0241331160800CC2CDB /* sqlite3.c in Sources */,
+ 073FA0251331160800CC2CDB /* stdafx.cpp in Sources */,
+ 073FA0261331160800CC2CDB /* ginkgoimagecommand.cpp in Sources */,
+- 073FA0271331160800CC2CDB /* hackimageactor.cpp in Sources */,
+ 073FA0281331160800CC2CDB /* ginkgointeractorstyleimage2d.cpp in Sources */,
+ 073FA0291331160800CC2CDB /* vtkginkgoimageviewer.cpp in Sources */,
+ 073FA02A1331160800CC2CDB /* vtkopenglginkgotexture.cpp in Sources */,
+diff -Nur ginkgocadx-2.14.0.4972.orig/src/cadxcore/vtk/hackimageactor.cpp ginkgocadx-2.14.0.4972/src/cadxcore/vtk/hackimageactor.cpp
+--- ginkgocadx-2.14.0.4972.orig/src/cadxcore/vtk/hackimageactor.cpp 2012-06-26 21:56:20.000000000 +1000
++++ ginkgocadx-2.14.0.4972/src/cadxcore/vtk/hackimageactor.cpp 1970-01-01 10:00:00.000000000 +1000
+@@ -1,93 +0,0 @@
+-/*
+- *
+- * $Id$
+- * Ginkgo CADx Project
+- *
+- * Copyright 2008-10 MetaEmotion S.L. All rights reserved.
+- * http://ginkgo-cadx.com
+- *
+- * This file is licensed under LGPL v3 license.
+- * See License.txt for details
+- *
+- * Code based in VTK
+- */
+-#include "hackimageactor.h"
+-#include <vtkRenderWindow.h>
+-#include <vtkgl.h>
+-
+-vtkHackedTempImageActor::vtkHackedTempImageActor(vtkImageActor* realActor)
+-{
+- vtkHackedTempImageActor* realhia = ((vtkHackedTempImageActor* ) ((vtkOpenGLImageActor*)realActor) );
+- m_IdTextura = realhia->Index;
+- m_vtkRenderWindow = realhia->RenderWindow;
+-
+- m_TextureDimensions[0] = realhia->TextureSize[0];
+- m_TextureDimensions[1] = realhia->TextureSize[1];
+- this->SetReferenceCount(0);
+-
+-}
+-
+-vtkHackedTempImageActor::~vtkHackedTempImageActor()
+-{
+-}
+-
+-long vtkHackedTempImageActor::GetTextureId() const
+-{
+- return m_IdTextura;
+-}
+-
+-const int* vtkHackedTempImageActor::GetTextureDimensions() const
+-{
+- return m_TextureDimensions;
+-}
+-
+- vtkHackedTempImageActor::operator long () const
+-{
+- return m_IdTextura;
+-}
+-
+-bool vtkHackedTempImageActor::TextureDefined() const
+-{
+- const unsigned int tid = m_IdTextura;
+-
+- if (m_vtkRenderWindow == NULL)
+- return false;
+-
+- return tid != 0;
+-}
+-
+- bool vtkHackedTempImageActor::TextureLoaded() const
+- {
+- int width;
+- if (m_IdTextura != 0) {
+- glEnable(GL_TEXTURE_2D);
+- glBindTexture(GL_TEXTURE_2D, m_IdTextura);
+- glGetTexLevelParameteriv(GL_TEXTURE_2D, 0, GL_TEXTURE_WIDTH, &width);
+- glBindTexture(GL_TEXTURE_2D, 0);
+-
+- // Supermegahackkkkkkkkkk!
+- if (glGetError() != 0)
+- return false;
+-
+- glDisable(GL_TEXTURE_2D);
+- if (width == m_TextureDimensions[0]) {
+- return true;
+- }
+- else {
+- return false;
+- }
+- }
+- return true;
+-
+- /*
+- GLboolean resident = GL_FALSE;
+- const unsigned int tid = m_IdTextura;
+- if (tid != 0) {
+- glAreTexturesResident(1, &tid, &resident);
+- }
+- else {
+- resident = GL_TRUE;
+- }
+- return (resident == GL_TRUE);
+- */
+- }
+diff -Nur ginkgocadx-2.14.0.4972.orig/src/cadxcore/vtk/hackimageactor.h ginkgocadx-2.14.0.4972/src/cadxcore/vtk/hackimageactor.h
+--- ginkgocadx-2.14.0.4972.orig/src/cadxcore/vtk/hackimageactor.h 2012-06-26 21:56:20.000000000 +1000
++++ ginkgocadx-2.14.0.4972/src/cadxcore/vtk/hackimageactor.h 1970-01-01 10:00:00.000000000 +1000
+@@ -1,46 +0,0 @@
+-/*
+- *
+- * $Id$
+- * Ginkgo CADx Project
+- *
+- * Copyright 2008-10 MetaEmotion S.L. All rights reserved.
+- * http://ginkgo-cadx.com
+- *
+- * This file is licensed under LGPL v3 license.
+- * See License.txt for details
+- *
+- * Code based in VTK
+- */
+-#pragma once
+-#ifdef __DEPRECATED
+-#undef __DEPRECATED
+-#endif
+-#include <vtkOpenGLImageActor.h>
+-
+-class vtkRenderWindow;
+-
+-
+-class vtkHackedTempImageActor : public vtkOpenGLImageActor {
+- public:
+- vtkHackedTempImageActor(vtkImageActor* realActor);
+-
+- ~vtkHackedTempImageActor();
+-
+- long GetTextureId() const;
+-
+- const int* GetTextureDimensions() const;
+-
+- //indica si la textura tiene id (se ha intentado cargar)
+- bool TextureDefined() const;
+-
+- //indica si la textura esta cargada
+- bool TextureLoaded() const;
+-
+- operator long () const;
+-
+- protected:
+- long m_IdTextura;
+- int m_TextureDimensions[2];
+-
+- vtkRenderWindow *m_vtkRenderWindow;
+-};
+diff -Nur ginkgocadx-2.14.0.4972.orig/src/cadxcore/vtk/vtkginkgoimageviewer.cpp ginkgocadx-2.14.0.4972/src/cadxcore/vtk/vtkginkgoimageviewer.cpp
+--- ginkgocadx-2.14.0.4972.orig/src/cadxcore/vtk/vtkginkgoimageviewer.cpp 2012-06-26 21:56:20.000000000 +1000
++++ ginkgocadx-2.14.0.4972/src/cadxcore/vtk/vtkginkgoimageviewer.cpp 2012-06-30 21:39:32.882135234 +1000
+@@ -74,7 +74,6 @@
+ #include <vtkMatrix4x4.h>
+ #include <vtkPointData.h>
+
+-#include <hackimageactor.h>
+
+ #define VTK_GINKGO_ZOOM_MIN 0.25f
+ #define VTK_GINKGO_ZOOM_MAX 200
+diff -Nur ginkgocadx-2.14.0.4972.orig/src/cadxcore/widgets/wlupa.cpp ginkgocadx-2.14.0.4972/src/cadxcore/widgets/wlupa.cpp
+--- ginkgocadx-2.14.0.4972.orig/src/cadxcore/widgets/wlupa.cpp 2012-06-26 21:56:20.000000000 +1000
++++ ginkgocadx-2.14.0.4972/src/cadxcore/widgets/wlupa.cpp 2012-06-30 21:40:00.775900866 +1000
+@@ -32,7 +32,6 @@
+ #include <vtkPointData.h>
+ #include <vtkBMPWriter.h>
+ #include <vtkginkgoimageviewer.h>
+-#include <vtkOpenGLImageActor.h>
+
+
+
+diff -Nur ginkgocadx-2.14.0.4972.orig/src/cadxcore/widgets/wlupa.h ginkgocadx-2.14.0.4972/src/cadxcore/widgets/wlupa.h
+--- ginkgocadx-2.14.0.4972.orig/src/cadxcore/widgets/wlupa.h 2012-06-26 21:56:20.000000000 +1000
++++ ginkgocadx-2.14.0.4972/src/cadxcore/widgets/wlupa.h 2012-06-30 21:39:32.875468281 +1000
+@@ -26,7 +26,6 @@
+ #endif
+ #include <vtkSmartPointer.h>
+ #include <vtkImageData.h>
+-#include <hackimageactor.h>
+
+ namespace GNC {
+ namespace GCS {
+diff -Nur ginkgocadx-2.14.0.4972.orig/src/visualizator/visualizator/vistas/vista2d.cpp ginkgocadx-2.14.0.4972/src/visualizator/visualizator/vistas/vista2d.cpp
+--- ginkgocadx-2.14.0.4972.orig/src/visualizator/visualizator/vistas/vista2d.cpp 2012-06-26 21:56:21.000000000 +1000
++++ ginkgocadx-2.14.0.4972/src/visualizator/visualizator/vistas/vista2d.cpp 2012-06-30 21:39:32.865467947 +1000
+@@ -67,7 +67,6 @@
+ #include <vtkAlgorithm.h>
+ #include <vtkAlgorithmOutput.h>
+ #include <vtkImageData.h>
+-#include <hackimageactor.h>
+ #include <vtkAlgorithmOutput.h>
+ #include <vtkInformation.h>
+
+diff -Nur ginkgocadx-2.14.0.4972.orig/src/visualizator/visualizator/vistas/waveformview.cpp ginkgocadx-2.14.0.4972/src/visualizator/visualizator/vistas/waveformview.cpp
+--- ginkgocadx-2.14.0.4972.orig/src/visualizator/visualizator/vistas/waveformview.cpp 2012-06-26 21:56:21.000000000 +1000
++++ ginkgocadx-2.14.0.4972/src/visualizator/visualizator/vistas/waveformview.cpp 2012-06-30 21:39:32.865467947 +1000
+@@ -60,7 +60,6 @@
+ #include <vtkAlgorithm.h>
+ #include <vtkAlgorithmOutput.h>
+ #include <vtkImageData.h>
+-#include <hackimageactor.h>
+ #include <vtkAlgorithmOutput.h>
+ #include <vtkInformation.h>
+ #include <vtkCamera.h>
+diff -Nur ginkgocadx-2.14.0.4972.orig/src/visualizator/visualizator/wxvtk/gvistacompleja.cpp ginkgocadx-2.14.0.4972/src/visualizator/visualizator/wxvtk/gvistacompleja.cpp
+--- ginkgocadx-2.14.0.4972.orig/src/visualizator/visualizator/wxvtk/gvistacompleja.cpp 2012-06-26 21:57:36.000000000 +1000
++++ ginkgocadx-2.14.0.4972/src/visualizator/visualizator/wxvtk/gvistacompleja.cpp 2012-06-30 21:39:32.872134808 +1000
+@@ -70,7 +70,6 @@
+ //#include <widgets/wprogreso.h>
+ #include <widgets/wanotacionesquina.h>
+
+-#include <hackimageactor.h>
+
+
+ #include "reconstruction/endoscopy.h"
+diff -Nur ginkgocadx-2.14.0.4972.orig/src/visualizator/visualizator/wxvtk/gvistasimple.cpp ginkgocadx-2.14.0.4972/src/visualizator/visualizator/wxvtk/gvistasimple.cpp
+--- ginkgocadx-2.14.0.4972.orig/src/visualizator/visualizator/wxvtk/gvistasimple.cpp 2012-06-26 21:57:36.000000000 +1000
++++ ginkgocadx-2.14.0.4972/src/visualizator/visualizator/wxvtk/gvistasimple.cpp 2012-06-30 21:39:32.868801389 +1000
+@@ -46,7 +46,6 @@
+ #include "../exportacion/iherramientaoverlays.h"
+
+ #include <widgets/openglhelper.h>
+-#include <hackimageactor.h>
+
+
+ class GVtkObserver: public vtkCommand