summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Schaffrath2019-04-25 04:30:11 +0200
committerPhilipp Schaffrath2019-04-25 04:30:11 +0200
commit4720071111c32281b7650d771ca6b4d7bb5c6cae (patch)
treecc314d900f39b2c511fa7af1b9f93bdd4372fc3d
downloadaur-4720071111c32281b7650d771ca6b4d7bb5c6cae.tar.gz
created PKGBUILD and .SRCINFO files
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17a956ca2c4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = giph-git
+ pkgdesc = gif recorder that records the desktop, a window or a selection
+ pkgver = r44.0a55fca
+ pkgrel = 1
+ url = https://github.com/phisch/giph
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = bash
+ depends = ffmpeg
+ depends = grep
+ depends = gawk
+ optdepends = slop: for interactive selection
+ optdepends = xorg-xwininfo: for window or desktop recording
+ optdepends = zenity: for a graphical user interface
+ optdepends = gifski: if the gifs should be encoded with gifski instead of ffmpeg
+ provides = giph
+ conflicts = giph
+ source = giph-git::git://github.com/phisch/giph.git
+ sha256sums = SKIP
+
+pkgname = giph-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5d5b89ca9bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Philipp Schaffrath <aur at philipp dot schaffrath dot email>
+
+pkgname=giph-git
+pkgver=r44.0a55fca
+pkgrel=1
+pkgdesc='gif recorder that records the desktop, a window or a selection'
+url='https://github.com/phisch/giph'
+license=('MIT')
+arch=('any')
+depends=('bash' 'ffmpeg' 'grep' 'gawk')
+optdepends=('slop: for interactive selection'
+ 'xorg-xwininfo: for window or desktop recording'
+ 'zenity: for a graphical user interface'
+ 'gifski: if the gifs should be encoded with gifski instead of ffmpeg')
+makedepends=('git')
+provides=('giph')
+conflicts=('giph')
+source=("$pkgname::git://github.com/phisch/giph.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file