summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaron-Prime2015-10-18 17:13:54 +0300
committerHaron-Prime2015-10-18 17:13:54 +0300
commit5a3471cd4e3fa88ba277f9ebd31d84d37053fdf8 (patch)
treeada507df973fd8a487933a057138530a177ce790
downloadaur-5a3471cd4e3fa88ba277f9ebd31d84d37053fdf8.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cca77b158c35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gis-weather
+ pkgdesc = Customizable weather widget
+ pkgver = 0.7.8.7
+ pkgrel = 1
+ url = http://sourceforge.net/projects/gis-weather
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ depends = gtk3
+ depends = python
+ depends = python-gobject
+ depends = python-cairo
+ optdepends = librsvg
+ conflicts = gis-weather-git
+ source = http://sourceforge.net/projects/gis-weather/files/gis-weather/0.7.8.7/gis-weather_0.7.8.7_all.deb/download
+ md5sums = dab6f428201125752c5fef6840866206
+
+pkgname = gis-weather
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cb81a342ac6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Haron Prime (Haron_Prime) <haron.prime@gmx.com>
+
+pkgname=gis-weather
+pkgver=0.7.8.7
+pkgrel=1
+pkgdesc="Customizable weather widget"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/gis-weather"
+license=('GPLv3')
+groups=()
+depends=('gtk3' 'python' 'python-gobject' 'python-cairo')
+optdepends=('librsvg')
+provides=()
+conflicts=('gis-weather-git')
+
+source=(${url}/files/gis-weather/${pkgver}/gis-weather_${pkgver}_all.deb/download)
+md5sums=('dab6f428201125752c5fef6840866206')
+
+package() {
+ cd "$srcdir"
+ tar -xf data.tar.xz -C "${pkgdir}"
+ echo "aur" > "${pkgdir}/usr/share/${pkgname}/package"
+ chmod -R 777 "${pkgdir}"/usr/share/${pkgname}
+ mkdir -p $pkgdir/usr/bin
+}