summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortypebrook2020-05-11 00:34:20 +0800
committertypebrook2020-05-11 00:34:20 +0800
commit157dac70c9077e1963ac6ee17d4c8e9b45780a28 (patch)
treef369a9caa01f70ba735355e2df164c25bc662325
downloadaur-157dac70c9077e1963ac6ee17d4c8e9b45780a28.tar.gz
Add basic package info
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebb02f46289a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gist-lite
+ pkgdesc = Manage your gist like a pro
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://gist.github.com/b0d2e7e67aa50298fdf8111ae7466b56
+ arch = any
+ license = GPL3
+ depends = git
+ depends = coreutils
+ depends = python
+ source = https://codeload.github.com/gist/b0d2e7e67aa50298fdf8111ae7466b56/tar.gz/0.1
+ md5sums = ffab52c1c233f726642d1d8eabfb39a6
+
+pkgname = gist-lite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6eb802262a19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: typebrook <typebrook@gmail.com>
+pkgname=gist-lite
+pkgver=0.1
+pkgrel=1
+pkgdesc="Manage your gist like a pro"
+arch=(any)
+gist_id=b0d2e7e67aa50298fdf8111ae7466b56
+url="https://gist.github.com/$gist_id"
+license=('GPL3')
+depends=(git coreutils python)
+source=(https://codeload.github.com/gist/$gist_id/tar.gz/$pkgver)
+md5sums=('ffab52c1c233f726642d1d8eabfb39a6')
+
+package() {
+ install -m0755 ${srcdir}/${gist_id}-${pkgver}/gist ${pkgdir}/usr/bin/gist
+}