summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortypebrook2020-05-14 00:00:30 +0800
committertypebrook2020-05-14 00:55:46 +0800
commitab7aa305172137f8c4623744a4327e3d9794e3dd (patch)
treea301daf4111f9d6900306ba26e041c00488caace
parent5320006f2c4ddd3aecca782bc11d6daf7519dcf5 (diff)
downloadaur-ab7aa305172137f8c4623744a4327e3d9794e3dd.tar.gz
Update to 0.4
Upstream v0.4 can varify helper message by script name, so it is OK to change script name - Install as /usr/bin/gist-lite - Show hint to user about alias after installation
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD32
-rw-r--r--msg.install10
3 files changed, 20 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50aafff1416a..129a581f202d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = gist-lite
pkgdesc = Bash script for gist management
- pkgver = 0.3
- pkgrel = 3
+ pkgver = 0.4
+ pkgrel = 1
url = https://gist.github.com/b0d2e7e67aa50298fdf8111ae7466b56
+ install = msg.install
arch = any
license = GPL3
depends = git
depends = coreutils
depends = python
- source = https://codeload.github.com/gist/b0d2e7e67aa50298fdf8111ae7466b56/tar.gz/v0.3
- md5sums = 599f16a275050b21a9cbfd67aa4fa307
+ source = https://codeload.github.com/gist/b0d2e7e67aa50298fdf8111ae7466b56/tar.gz/v0.4
+ md5sums = 5c410fa9b6eabab7b28bb1bab215dd81
pkgname = gist-lite
diff --git a/PKGBUILD b/PKGBUILD
index 044811cab8c4..64c136e85f56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hsieh Chin Fan <typebrook@gmail.com>
pkgname=gist-lite
-pkgver=0.3
-pkgrel=3
+pkgver=0.4
+pkgrel=1
pkgdesc="Bash script for gist management"
arch=(any)
gist_id=b0d2e7e67aa50298fdf8111ae7466b56
@@ -9,31 +9,9 @@ url="https://gist.github.com/$gist_id"
license=('GPL3')
depends=(git coreutils python)
source=(https://codeload.github.com/gist/$gist_id/tar.gz/v$pkgver)
-md5sums=('599f16a275050b21a9cbfd67aa4fa307')
+md5sums=('5c410fa9b6eabab7b28bb1bab215dd81')
+install=msg.install
package() {
- local filename=gist
-
- if [[ -n $(pacman -Qqe gist 2>/dev/null) ]]; then
- echo 'Package "gist" is already installed'
- echo
- PS3='Please enter your choice(1 or 2), or name this script by yourself: '
- choices=('Install this script as "gist-lite"' 'Abort installation')
- select ans in "${choices[@]}"; do
- case $ans in
- ${choices[0]}) filename=gist-lite; break ;;
- ${choices[1]}) exit 0 ;;
- *)
- if [[ -n $(which $REPLY 2>/dev/null) ]]; then
- echo 'Invalid name, it is already in PATH'
- else
- filename=$REPLY
- break
- fi
- ;;
- esac
- done
- fi
-
- install -Dm0755 ${srcdir}/${gist_id}-${pkgver}/gist ${pkgdir}/usr/bin/$filename 2>/dev/tty
+ install -Dm0755 ${srcdir}/${gist_id}-${pkgver}/gist ${pkgdir}/usr/bin/${pkgname}
}
diff --git a/msg.install b/msg.install
new file mode 100644
index 000000000000..55a63e383d87
--- /dev/null
+++ b/msg.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo
+ echo
+ echo ":: gist-lite is installed"
+ echo "If you want to make it consistent with upstream"
+ echo "You can add the following command into your shell configuration file (like ~/.bashrc):"
+ echo " alias gist='GISTSCRIPT=gist /usr/bin/gist-lite'"
+ echo
+ echo
+}