summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshi chao gao2018-11-25 13:32:52 +0800
committershi chao gao2018-11-25 13:32:52 +0800
commit1677613957fbf2d95eda785ac5e5319e9e02a72f (patch)
treed4f4b48b8dc68d93b8f99fa63d6d1589d450366b
parent34b0f3ce88935e63a2be6acb0e5c3190e1a65902 (diff)
downloadaur-1677613957fbf2d95eda785ac5e5319e9e02a72f.tar.gz
add, update
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD42
-rw-r--r--gisto.install19
3 files changed, 35 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb8a9fc028fc..f7edba0cba76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = gisto
pkgdesc = Cross-platform gist snippets management desktop application that allows you and your team share code snippets fast and easily. Based on GitHub Gist Infrastructure which means you can use all your existing snippets by connecting your GitHub account.
- pkgver = 0.3.1
+ pkgver = 1.10.17
pkgrel = 1
url = http://www.gistoapp.com/
- arch = i686
+ install = gisto.install
arch = x86_64
license = MIT
- depends = gconf
- depends = ttf-ms-fonts
+ depends = nss
+ depends = gtk3
+ depends = libxss
options = !strip
- source = http://download.gistoapp.com/Gisto-0.3.1-Linux_x86.tar.gz
- md5sums = 278127a3d3367b62f6fec3bfb480171a
+ source = https://github.com/Gisto/Gisto/releases/download/v1.10.17/Gisto-1.10.17-amd64.deb
+ md5sums = d3c6603991108d6038f19c447e39fc04
pkgname = gisto
diff --git a/PKGBUILD b/PKGBUILD
index 87a1395d4bad..a7bbb967afd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,20 @@
# Maintainer: Sasha Khamkov <sanusart@gmail.com>
+# Maintainer: xgdgsc <xgdgsc at gmail dot com>
pkgname=gisto
-pkgver=0.3.1
+pkgver=1.10.17
pkgrel=1
epoch=
pkgdesc="Cross-platform gist snippets management desktop application that allows you and your team share code snippets fast and easily. Based on GitHub Gist Infrastructure which means you can use all your existing snippets by connecting your GitHub account."
-arch=("i686" "x86_64")
+arch=("x86_64")
url="http://www.gistoapp.com/"
license=("MIT")
groups=()
options=(!strip)
-depends=("gconf" "ttf-ms-fonts")
-
-_gisto_arch="x86"
-_gisto_arch_name="i32"
-[ "$CARCH" = "x86_64" ] && _gisto_arch="x86_64" && _gisto_arch_name="x64"
-
-source=("http://download.gistoapp.com/Gisto-$pkgver-Linux_${_gisto_arch}.tar.gz")
-
-md5sums=('278127a3d3367b62f6fec3bfb480171a')
-[ "$CARCH" = "x86_64" ] && md5sums[0]='f140042d45b965695c5e4c3862daaaf3'
-
+depends=("nss" "gtk3" "libxss")
+# PKGEXT=.tar
+install=${pkgname}.install
+source=("https://github.com/Gisto/Gisto/releases/download/v$pkgver/Gisto-$pkgver-amd64.deb")
+md5sums=('d3c6603991108d6038f19c447e39fc04')
package() {
-
- printf "\n\n\n\e[43m \e[0m INSTALLING...\n\n\n------------\n\n\n"
-
- printf "\e[43m \e[0m CREATE PACKAGE STRUCTURE \n\n\n"
- mkdir -p $pkgdir/{opt,usr/bin}
-
- cp -R $srcdir/Gisto-$pkgver-linux_${_gisto_arch_name}/gisto $pkgdir/opt/
- cp -R $srcdir/Gisto-$pkgver-linux_${_gisto_arch_name}/share $pkgdir/usr/
-
- printf "\e[43m \e[0m APPLY LIBUDEV FIX \n\n\n"
-
- mkdir -p $pkgdir/opt/gisto/lib
- ln -sf /usr/lib/libudev.so.1 $pkgdir/opt/gisto/lib/libudev.so.0
-
- printf "\e[43m \e[0m CREATE GISTO SYSTEM LINK \n\n\n"
-
- ln -sf /opt/gisto/gisto $pkgdir/usr/bin/gisto
-
- printf "\e[43m \e[0m DONE PREPARATIONS :) \n\n\n"
-
+ tar xf data.tar.xz -C "${pkgdir}"
}
diff --git a/gisto.install b/gisto.install
new file mode 100644
index 000000000000..3f534a3a3654
--- /dev/null
+++ b/gisto.install
@@ -0,0 +1,19 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf '/opt/Gisto/gisto' '/usr/bin/gisto'
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Delete the link to the binary
+ rm -f '/usr/bin/gisto'
+ update-desktop-database -q
+}