summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYann Büchau2022-12-22 11:00:06 +0100
committerYann Büchau2022-12-22 11:12:20 +0100
commitfa18f150a939721240b62d8fe2e8b6720d9d5a56 (patch)
tree7aa61ed66a2ba83bf7e88dc699cdf323c16b69fc
downloadaur-fa18f150a939721240b62d8fe2e8b6720d9d5a56.tar.gz
🎉 Initial version
-rw-r--r--.SRCINFO99
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD62
3 files changed, 165 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a63b6bc8b21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,99 @@
+pkgbase = git-annex-git
+ pkgdesc = Manage files with git, without checking their contents into git (dev version)
+ pkgver = 10.20221212.r24.gac6ccb513
+ pkgrel = 1
+ url = https://git-annex.branchable.com/
+ arch = x86_64
+ license = AGPL3
+ makedepends = chrpath
+ makedepends = ghc
+ makedepends = uusi
+ depends = git
+ depends = lsof
+ depends = rsync
+ depends = ghc-libs
+ depends = haskell-aeson
+ depends = haskell-ansi-terminal
+ depends = haskell-async
+ depends = haskell-aws
+ depends = haskell-blaze-builder
+ depends = haskell-bloomfilter
+ depends = haskell-byteable
+ depends = haskell-case-insensitive
+ depends = haskell-clientsession
+ depends = haskell-concurrent-output
+ depends = haskell-connection
+ depends = haskell-conduit
+ depends = haskell-criterion
+ depends = haskell-crypto-api
+ depends = haskell-cryptonite
+ depends = haskell-data-default
+ depends = haskell-dav
+ depends = haskell-dbus
+ depends = haskell-disk-free-space
+ depends = haskell-dlist
+ depends = haskell-edit-distance
+ depends = haskell-fdo-notify
+ depends = haskell-feed
+ depends = haskell-filepath-bytestring
+ depends = haskell-git-lfs
+ depends = haskell-hinotify
+ depends = haskell-http-client
+ depends = haskell-http-client-restricted
+ depends = haskell-http-client-tls
+ depends = haskell-http-conduit
+ depends = haskell-http-types
+ depends = haskell-ifelse
+ depends = haskell-magic
+ depends = haskell-memory
+ depends = haskell-microlens
+ depends = haskell-monad-control
+ depends = haskell-monad-logger
+ depends = haskell-mountpoints
+ depends = haskell-network
+ depends = haskell-network-info
+ depends = haskell-network-multicast
+ depends = haskell-network-uri
+ depends = haskell-old-locale
+ depends = haskell-optparse-applicative
+ depends = haskell-path-pieces
+ depends = haskell-persistent
+ depends = haskell-persistent-sqlite
+ depends = haskell-quickcheck
+ depends = haskell-random
+ depends = haskell-regex-tdfa
+ depends = haskell-resourcet
+ depends = haskell-safesemaphore
+ depends = haskell-sandi
+ depends = haskell-securemem
+ depends = haskell-shakespeare
+ depends = haskell-socks
+ depends = haskell-split
+ depends = haskell-stm-chans
+ depends = haskell-tagsoup
+ depends = haskell-tasty
+ depends = haskell-tasty-hunit
+ depends = haskell-tasty-quickcheck
+ depends = haskell-tasty-rerun
+ depends = haskell-torrent
+ depends = haskell-unix-compat
+ depends = haskell-unliftio-core
+ depends = haskell-unordered-containers
+ depends = haskell-utf8-string
+ depends = haskell-uuid
+ depends = haskell-vector
+ depends = haskell-wai
+ depends = haskell-wai-extra
+ depends = haskell-warp
+ depends = haskell-warp-tls
+ depends = haskell-yesod
+ depends = haskell-yesod-core
+ depends = haskell-yesod-form
+ depends = haskell-yesod-static
+ provides = git-annex
+ conflicts = git-annex
+ conflicts = git-annex-standalone
+ source = git+https://git.joeyh.name/git/git-annex.git
+ sha512sums = SKIP
+
+pkgname = git-annex-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..be759443a382
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.pkg*
+*git-annex*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e82b90a3d58e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Yann Büchau <nobodyinperson at posteo de>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Arch Haskell Team <arch-haskell@haskell.org>
+
+pkgname=git-annex-git
+pkgver=10.20221212.r24.gac6ccb513
+pkgrel=1
+pkgdesc="Manage files with git, without checking their contents into git (dev version)"
+url="https://git-annex.branchable.com/"
+license=("AGPL3")
+arch=('x86_64')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}" 'git-annex-standalone')
+depends=('git' 'lsof' 'rsync' 'ghc-libs' 'haskell-aeson' 'haskell-ansi-terminal' 'haskell-async'
+ 'haskell-aws' 'haskell-blaze-builder' 'haskell-bloomfilter' 'haskell-byteable'
+ 'haskell-case-insensitive' 'haskell-clientsession' 'haskell-concurrent-output'
+ 'haskell-connection' 'haskell-conduit' 'haskell-criterion' 'haskell-crypto-api'
+ 'haskell-cryptonite' 'haskell-data-default' 'haskell-dav' 'haskell-dbus'
+ 'haskell-disk-free-space' 'haskell-dlist' 'haskell-edit-distance' 'haskell-fdo-notify'
+ 'haskell-feed' 'haskell-filepath-bytestring' 'haskell-git-lfs' 'haskell-hinotify'
+ 'haskell-http-client' 'haskell-http-client-restricted' 'haskell-http-client-tls'
+ 'haskell-http-conduit' 'haskell-http-types' 'haskell-ifelse' 'haskell-magic'
+ 'haskell-memory' 'haskell-microlens' 'haskell-monad-control' 'haskell-monad-logger'
+ 'haskell-mountpoints' 'haskell-network' 'haskell-network-info' 'haskell-network-multicast'
+ 'haskell-network-uri' 'haskell-old-locale' 'haskell-optparse-applicative'
+ 'haskell-path-pieces' 'haskell-persistent' 'haskell-persistent-sqlite' 'haskell-quickcheck'
+ 'haskell-random' 'haskell-regex-tdfa' 'haskell-resourcet' 'haskell-safesemaphore'
+ 'haskell-sandi' 'haskell-securemem' 'haskell-shakespeare' 'haskell-socks' 'haskell-split'
+ 'haskell-stm-chans' 'haskell-tagsoup' 'haskell-tasty' 'haskell-tasty-hunit'
+ 'haskell-tasty-quickcheck' 'haskell-tasty-rerun' 'haskell-torrent' 'haskell-unix-compat'
+ 'haskell-unliftio-core' 'haskell-unordered-containers' 'haskell-utf8-string' 'haskell-uuid'
+ 'haskell-vector' 'haskell-wai' 'haskell-wai-extra' 'haskell-warp' 'haskell-warp-tls'
+ 'haskell-yesod' 'haskell-yesod-core' 'haskell-yesod-form' 'haskell-yesod-static')
+makedepends=('chrpath' 'ghc' 'uusi')
+source=("git+https://git.joeyh.name/git/git-annex.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/"${pkgname%-git}"
+ git describe --long --tags --always | sed 's/^[^0-9]\+//g;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd git-annex
+ # persistent-template was merged into persistent
+ uusi -d persistent-template git-annex.cabal
+ sed -i 's/MIN_VERSION_persistent_template/MIN_VERSION_persistent/' Database/ContentIdentifier.hs Database/Export.hs Database/Fsck.hs Database/Keys/SQL.hs
+}
+
+build() {
+ cd git-annex
+ sed -e 's|--ghc-options|-O --prefix=/usr --enable-executable-dynamic --disable-library-vanilla --docdir=/usr/share/doc/'${pkgname%-git}' --ghc-options|' \
+ -i Makefile
+ make GHC="ghc -dynamic" BUILDER=./Setup BUILDEROPTIONS=$MAKEFLAGS
+}
+
+package() {
+ cd git-annex
+ make GHC="ghc -dynamic" BUILDER=./Setup DESTDIR="$pkgdir" install
+
+ rmdir "$pkgdir"/usr/share/doc/git-annex "$pkgdir"/usr/share/doc
+}