summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Nixon2016-04-29 11:40:08 +0100
committerChris Nixon2016-04-29 11:40:08 +0100
commit1326e19ad7a7f952ca784e97e0929ea05dc4f8d6 (patch)
treed619da4b52c6fd4441744a33129f23b95a2863dc
parent4d69ce9441ae76c325ddcb8af8fb835b6c298fe2 (diff)
downloadaur-1326e19ad7a7f952ca784e97e0929ea05dc4f8d6.tar.gz
Removed unnecessarily duplicated build step
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c98fb79bc964..4b6694b72543 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = git-annex-stack
pkgdesc = manage files with git, without checking their contents into git (stack build)
- pkgver = 6.20160419.r9.g4482caf
+ pkgver = 6.20160419.r10.g24c224f
pkgrel = 1
url = http://git-annex.branchable.com/
arch = i686
@@ -21,7 +21,7 @@ pkgbase = git-annex-stack
depends = openssh
depends = rsync
depends = util-linux
- provides = git-annex=6.20160419.r9.g4482caf
+ provides = git-annex=6.20160419.r10.g24c224f
conflicts = git-annex-git
conflicts = git-annex
conflicts = git-annex-cabal
diff --git a/PKGBUILD b/PKGBUILD
index 44c91ac5f88b..c2c25bd29894 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=git-annex-stack
pkgdesc='manage files with git, without checking their contents into git (stack build)'
-pkgver=6.20160419.r9.g4482caf
+pkgver=6.20160419.r10.g24c224f
pkgrel=1
url='http://git-annex.branchable.com/'
@@ -74,7 +74,8 @@ build() {
msg2 "Features: ${_features[*]}"
stack init --force --system-ghc
stack setup
- stack build $_stack_flags
+ mkdir -p "bin"
+ stack install --local-bin-path "bin" $_stack_flags
}
# This involves a recompile, uncomment if you're patient.
@@ -84,7 +85,6 @@ build() {
# }
package() {
- cd git-annex
mkdir -p "$pkgdir/usr/bin"
- stack install --local-bin-path "$pkgdir/usr/bin"
+ cp git-annex/bin/* "$pkgdir/usr/bin"
}