summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Nixon2016-04-29 11:05:49 +0100
committerChris Nixon2016-04-29 11:18:06 +0100
commit4d69ce9441ae76c325ddcb8af8fb835b6c298fe2 (patch)
treea42c6475a560d510fdeeecf406b6b9ef2fd8c6d6
downloadaur-4d69ce9441ae76c325ddcb8af8fb835b6c298fe2.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD90
2 files changed, 123 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c98fb79bc964
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = git-annex-stack
+ pkgdesc = manage files with git, without checking their contents into git (stack build)
+ pkgver = 6.20160419.r9.g4482caf
+ pkgrel = 1
+ url = http://git-annex.branchable.com/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = ghc
+ makedepends = haskell-stack
+ makedepends = dbus
+ depends = curl
+ depends = git
+ depends = gmp
+ depends = gnupg
+ depends = gsasl
+ depends = libidn
+ depends = libxml2
+ depends = lsof
+ depends = nss-mdns
+ depends = openssh
+ depends = rsync
+ depends = util-linux
+ provides = git-annex=6.20160419.r9.g4482caf
+ conflicts = git-annex-git
+ conflicts = git-annex
+ conflicts = git-annex-cabal
+ options = !makeflags
+ source = git-annex::git://git.kitenet.net/git-annex
+ sha256sums = SKIP
+
+pkgname = git-annex-stack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44c91ac5f88b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,90 @@
+# Maintainer: Chris Nixon <chris.nixon@sigma.me.uk>
+
+pkgname=git-annex-stack
+pkgdesc='manage files with git, without checking their contents into git (stack build)'
+pkgver=6.20160419.r9.g4482caf
+pkgrel=1
+
+url='http://git-annex.branchable.com/'
+license=(GPL3)
+arch=('i686' 'x86_64')
+
+# Please report missing dependencies (and your $_features setting below)
+depends=(curl git gmp gnupg gsasl libidn libxml2 lsof nss-mdns openssh rsync util-linux)
+options=(!makeflags)
+conflicts=(git-annex-git git-annex git-annex-cabal)
+provides=("git-annex=$pkgver")
+makedepends=(ghc haskell-stack)
+source=("git-annex::git://git.kitenet.net/git-annex")
+sha256sums=('SKIP')
+
+# The following flags are used when building git-annex.
+# Features can be disabled by prepending them with a dash in $_features below.
+# You can use this to disable the webapp, for example (→ less build time).
+
+# S3 ............. Enable S3 support
+# WebDAV ......... Enable WebDAV support
+# Dbus ........... Enable dbus support
+# Assistant ...... Enable git-annex assistant and watch command
+# Webapp ......... Enable git-annex webapp
+# Pairing ........ Enable pairing
+# XMPP ........... Enable notifications using XMPP
+# Production ..... Enable production build (slower build; faster binary)
+# -Android ....... Cross building for Android
+# -AndroidSplice . Building to get TH splices for Android
+# TestSuite ...... Embed the test suite into git-annex
+# -EKG ........... Enable use of EKG to monitor git-annex as it runs
+
+_features=(
+ S3
+ -WebDAV
+ Dbus
+ Assistant
+ Webapp
+ Pairing
+ -XMPP
+ Production
+ -Android
+ -AndroidSplice
+ TestSuite
+ -EKG
+)
+
+
+case " ${_features[@]}" in
+ *" Dbus"*)
+ makedepends=("${makedepends[@]}" dbus)
+ ;;&
+esac
+
+_stack_flags=$(printf '%s\n' "${_features[@]}" | xargs -n1 -I% echo --flag 'git-annex:%')
+
+prepare(){
+ cd "git-annex"
+ git checkout $(git describe)
+
+}
+pkgver(){
+ cd "git-annex"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd git-annex
+ msg2 "Features: ${_features[*]}"
+ stack init --force --system-ghc
+ stack setup
+ stack build $_stack_flags
+}
+
+# This involves a recompile, uncomment if you're patient.
+# check() {
+# cd git-annex
+# stack test
+# }
+
+package() {
+ cd git-annex
+ mkdir -p "$pkgdir/usr/bin"
+ stack install --local-bin-path "$pkgdir/usr/bin"
+}