summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Maslowski2020-12-30 03:51:24 +0100
committerDaniel Maslowski2020-12-30 03:51:24 +0100
commitec29be962be6a691b290503b67e32e6784e4fbe7 (patch)
treea83d6fa826c0bd843354edfc534d7be96b68a8bb
parent4ad43c966494e1f022a9f7c0341a14a9c7e8d6be (diff)
downloadaur-ec29be962be6a691b290503b67e32e6784e4fbe7.tar.gz
v0.10.1
This fixes the license, install command, and new upstream location.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa85c239c656..d02066618579 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-# Generated by mksrcinfo v8
-# Sat Apr 30 00:29:03 UTC 2016
pkgbase = git-big-picture
pkgdesc = Visualization tool for Git repositories
- pkgver = 0.9.0
- pkgrel = 3
- url = https://github.com/esc/git-big-picture
+ pkgver = 0.10.1
+ pkgrel = 1
+ url = https://github.com/git-big-picture/git-big-picture
arch = any
- license = GPL
+ license = GPL3
makedepends = git
- depends = python2
+ depends = python
depends = git
depends = graphviz
provides = git-big-picture
- source = git+https://github.com/esc/git-big-picture.git
- md5sums = SKIP
+ source = https://github.com/git-big-picture/git-big-picture/archive/v0.10.1.tar.gz
+ md5sums = 7198106c60213fe99889f573be74557f
pkgname = git-big-picture
diff --git a/PKGBUILD b/PKGBUILD
index 36d985af6824..76c6bc218066 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Daniel Maslowski <info@orangecms.org>
pkgname=git-big-picture
-pkgver=0.9.0
-pkgrel=3
+pkgver=0.10.1
+pkgrel=1
pkgdesc="Visualization tool for Git repositories"
arch=('any')
-url="https://github.com/esc/git-big-picture"
-license=('GPL')
-depends=('python2' 'git' 'graphviz')
+url="https://github.com/git-big-picture/git-big-picture"
+license=('GPL3')
+depends=('python' 'git' 'graphviz')
makedepends=('git')
provides=('git-big-picture')
-source=("git+https://github.com/esc/git-big-picture.git")
-md5sums=('SKIP')
+source=("https://github.com/git-big-picture/git-big-picture/archive/v$pkgver.tar.gz")
+md5sums=('7198106c60213fe99889f573be74557f')
package() {
- sed -i '0,/python/s/python/python2/' "${srcdir}/${pkgname}/${pkgname}"
- install -Dm755 "${srcdir}/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
}