summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2018-08-19 23:12:36 -0400
committerJean Lucas2018-08-19 23:12:36 -0400
commit8f84b257d5a95630403a12a2661b1f7161d09468 (patch)
treec9c8f51590660e8c8f031aad21808adb7a6632fc
parentf2a1d4235b6adadcfa52c76885831acd5ba640be (diff)
downloadaur-8f84b257d5a95630403a12a2661b1f7161d09468.tar.gz
Add man pages and shell completions
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d97abb6866af..97e1f03ed4eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Aug 17 16:30:38 UTC 2018
+# Mon Aug 20 03:12:11 UTC 2018
pkgbase = git-bug-git
pkgdesc = Distributed bug tracker embedded in Git (git)
- pkgver = 0.2.0+1+gc974cc0
+ pkgver = 0.2.0+15+g8abf984
pkgrel = 1
url = https://github.com/MichaelMure/git-bug
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 65e17af0a857..9635117feea5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=git-bug-git
-pkgver=0.2.0+1+gc974cc0
+pkgver=0.2.0+15+g8abf984
pkgrel=1
pkgdesc='Distributed bug tracker embedded in Git (git)'
arch=(i686 x86_64)
@@ -26,6 +26,10 @@ build() {
package() {
cd git-bug
install -D bin/git-bug "$pkgdir"/usr/bin/git-bug
- install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/git-bug
- install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/git-bug
+ install -Dm 644 -t "$pkgdir"/usr/share/bash-completion/completions misc/bash_completion/git-bug
+ install -Dm 644 misc/zsh_completion/git-bug "$pkgdir"/usr/share/zsh/site-functions/_git-bug
+ for f in doc/man/*.1; do gzip -n9f $f; done
+ install -Dm 644 -t "$pkgdir"/usr/share/man/man1 doc/man/*.1.gz
+ install -Dm 644 -t "$pkgdir"/usr/share/doc/git-bug README.md
+ install -Dm 644 -t "$pkgdir"/usr/share/licenses/git-bug LICENSE
}