summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2018-10-04 08:49:17 -0700
committerBenjamin Denhartog2018-10-04 08:49:17 -0700
commit5020c4c1f4c44500b7bf66f736de519568bffd0a (patch)
tree7d8581c44135287d6c87cd3396d4a49d21a44a9f
downloadaur-5020c4c1f4c44500b7bf66f736de519568bffd0a.tar.gz
initial upload: git-cleanup 1.0.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4169e175a16b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = git-cleanup
+ pkgdesc = Easily remove merged and deleted branches from local and remote repositories.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/sudoforge/git-cleanup
+ arch = any
+ license = MIT
+ depends = git
+ source = git-cleanup-1.0.0.tar.gz::https://github.com/sudoforge/git-cleanup/archive/1.0.0.tar.gz
+ sha256sums = 9d562d99785ea9a02a686a0b54074c8cb70be7e0d36f773e51f43bcf30b4d9a9
+
+pkgname = git-cleanup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aeab9e168c6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Benjamin Denhartog <ben@sudoforge.com>
+
+# This PKGBUILD is managed at https://github.com/sudoforge/pkgbuilds
+
+pkgname=git-cleanup
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Easily remove merged and deleted branches from local and remote repositories."
+arch=('any')
+url="https://github.com/sudoforge/${pkgname}"
+license=('MIT')
+depends=('git')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('9d562d99785ea9a02a686a0b54074c8cb70be7e0d36f773e51f43bcf30b4d9a9')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}