summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe Contreras2022-09-09 13:58:25 -0500
committerFelipe Contreras2022-09-09 13:58:25 -0500
commit82a977964909990e13d0b39269bd7079ce914972 (patch)
treea705fb9c53d70077138071ae6129d9658e78b553
parentcea7f49f8dfa9af843d9a28e12df4128ca167852 (diff)
downloadaur-82a977964909990e13d0b39269bd7079ce914972.tar.gz
Use release tarball
Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea1bfdd3d2bd..adb89546d9c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = git-completion
arch = any
license = GPL2
makedepends = git
- source = git-completion::git+https://github.com/felipec/git-completion.git#tag=v1.4
- sha256sums = SKIP
+ source = https://github.com/felipec/git-completion/archive/v1.4.tar.gz
+ sha1sums = e969109cafff4909b4421d709e4905a2b52b8a99
pkgname = git-completion
diff --git a/PKGBUILD b/PKGBUILD
index a80a130d1709..40d8767d0cf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,16 +8,16 @@ url="https://github.com/felipec/$pkgname"
arch=('any')
license=('GPL2')
makedepends=('git')
-source=("$pkgname::git+$url.git#tag=v$pkgver")
-sha256sums=('SKIP')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha1sums=('e969109cafff4909b4421d709e4905a2b52b8a99')
check() {
- cd $pkgname &&
+ cd "$pkgname-$pkgver"
make test
}
package() {
- cd $pkgname &&
+ cd "$pkgname-$pkgver"
# TODO find a better location than /usr/local/share
DESTDIR="$pkgdir/" make \
zshfuncdir=/usr/share/zsh/site-functions \