summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe Contreras2020-12-31 19:21:14 -0600
committerFelipe Contreras2020-12-31 19:21:59 -0600
commit910c901b2255bc975bc22ecc84fff1ea2c6cded7 (patch)
tree444ec40047edda0baac7c350aea8aaa82f12a044
downloadaur-910c901b2255bc975bc22ecc84fff1ea2c6cded7.tar.gz
Initial commit
Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74e0728a3088
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = git-completion
+ pkgdesc = Git completions for Zsh and Bash
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://github.com/felipec/git-completion
+ arch = any
+ license = GPLv2
+ makedepends = git
+ source = git-completion::git+https://github.com/felipec/git-completion.git#tag=v1.3
+ sha256sums = SKIP
+
+pkgname = git-completion
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4d67ab491cc3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/git-completion
+/*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c46d1f9d8bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Felipe Contreras <felipe.contreras@gmail.com>
+
+pkgname=git-completion
+pkgver=1.3
+pkgrel=1
+pkgdesc='Git completions for Zsh and Bash'
+url='https://github.com/felipec/git-completion'
+arch=('any')
+license=('GPLv2')
+makedepends=('git')
+source=("git-completion::git+$url.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+check() {
+ cd git-completion &&
+ make test
+}
+
+package() {
+ cd git-completion &&
+ # TODO find a better location than /usr/local/share
+ DESTDIR="$pkgdir" make \
+ zshfuncdir=/usr/share/zsh/site-functions \
+ completionsdir=/usr/local/share/bash-completion/completions \
+ sharedir=/usr/share/git-completion \
+ install
+}