summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe Contreras2022-09-09 13:57:59 -0500
committerFelipe Contreras2022-09-09 13:57:59 -0500
commitcea7f49f8dfa9af843d9a28e12df4128ca167852 (patch)
tree6984426224ff5e1396e3d7ea0107972e684b40de
parentd96b4c4c8bb48110ae9f3425a57bd57ebbfe107a (diff)
downloadaur-cea7f49f8dfa9af843d9a28e12df4128ca167852.tar.gz
Cleanup
Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD22
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59fadc324393..ea1bfdd3d2bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = git-completion
pkgrel = 1
url = https://github.com/felipec/git-completion
arch = any
- license = GPLv2
+ license = GPL2
makedepends = git
source = git-completion::git+https://github.com/felipec/git-completion.git#tag=v1.4
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9a1838260342..a80a130d1709 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,27 @@
# Maintainer: Felipe Contreras <felipe.contreras@gmail.com>
-# shellcheck disable=SC2154,SC2115
-
pkgname=git-completion
pkgver=1.4
pkgrel=1
pkgdesc='Git completions for Zsh and Bash'
url="https://github.com/felipec/$pkgname"
arch=('any')
-license=('GPLv2')
+license=('GPL2')
makedepends=('git')
source=("$pkgname::git+$url.git#tag=v$pkgver")
sha256sums=('SKIP')
check() {
- cd $pkgname &&
- make test
+ cd $pkgname &&
+ make test
}
package() {
- cd $pkgname &&
- # TODO find a better location than /usr/local/share
- DESTDIR="$pkgdir" make \
- zshfuncdir=/usr/share/zsh/site-functions \
- completionsdir=/usr/local/share/bash-completion/completions \
- sharedir=/usr/share/git-completion \
- install
+ cd $pkgname &&
+ # TODO find a better location than /usr/local/share
+ DESTDIR="$pkgdir/" make \
+ zshfuncdir=/usr/share/zsh/site-functions \
+ completionsdir=/usr/local/share/bash-completion/completions \
+ sharedir=/usr/share/git-completion \
+ install
}