summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbobpaul2018-05-16 13:42:53 -0500
committerbobpaul2018-05-16 13:42:53 -0500
commit379d0387234b01c1588d5cd4927a97d7d080f7d3 (patch)
treecfc178228ca8bb3e2d5a8b9ef1e7f9600722e908
downloadaur-379d0387234b01c1588d5cd4927a97d7d080f7d3.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD50
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e00b627b661
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = git-crecord-git
+ pkgdesc = Git subcommand to interactively select changes to commit or stage
+ pkgver = 20161216.0.r4.g30c7f4c
+ pkgrel = 1
+ url = https://github.com/andrewshadura/git-crecord
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2
+ source = git+https://github.com/andrewshadura/git-crecord.git
+ md5sums = SKIP
+
+pkgname = git-crecord-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01653e1a309b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: bobpaul <aurpackage [at] bobpaul 'period' org>
+pkgname="git-crecord-git"
+pkgver=20161216.0.r4.g30c7f4c
+pkgrel=1
+epoch=
+pkgdesc="Git subcommand to interactively select changes to commit or stage"
+arch=(any)
+url="https://github.com/andrewshadura/git-crecord"
+license=('GPL')
+groups=()
+depends=('python2')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(git+https://github.com/andrewshadura/git-crecord.git)
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+#prepare() {
+# cd "$pkgname-$pkgver"
+# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+#}
+
+build() {
+ cd "$pkgname"
+ ./setup.py build
+}
+
+pkgver(){
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+check() {
+ cd "$pkgname"
+ ./setup.py test
+}
+
+package() {
+ cd "$pkgname"
+ ./setup.py install --prefix=/usr --root="${pkgdir}" -O1 --skip-build
+}