summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbobpaul2018-05-16 13:49:46 -0500
committerbobpaul2018-05-16 13:49:46 -0500
commit7269b97738787d3cb6c58fc34fc59564394916ea (patch)
treec27cd149ac821beb08a34343bb7d2b2cd54dcbb5
parent379d0387234b01c1588d5cd4927a97d7d080f7d3 (diff)
downloadaur-7269b97738787d3cb6c58fc34fc59564394916ea.tar.gz
fixed issue with last minute package rename
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e00b627b661..2ba20e8f5d9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = git-crecord-git
pkgdesc = Git subcommand to interactively select changes to commit or stage
pkgver = 20161216.0.r4.g30c7f4c
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/andrewshadura/git-crecord
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 01653e1a309b..a5911707b946 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: bobpaul <aurpackage [at] bobpaul 'period' org>
pkgname="git-crecord-git"
pkgver=20161216.0.r4.g30c7f4c
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="Git subcommand to interactively select changes to commit or stage"
arch=(any)
@@ -29,22 +29,24 @@ validpgpkeys=()
# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
#}
+
+builddir="${pkgname/-git/}"
build() {
- cd "$pkgname"
+ cd "$builddir"
./setup.py build
}
pkgver(){
- cd "$pkgname"
+ cd "$builddir"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
check() {
- cd "$pkgname"
+ cd "$builddir"
./setup.py test
}
package() {
- cd "$pkgname"
+ cd "$builddir"
./setup.py install --prefix=/usr --root="${pkgdir}" -O1 --skip-build
}