summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Bender2022-05-18 13:07:19 +0200
committerErik Bender2022-05-18 13:07:19 +0200
commita9ddf854cbedfba62f560ddc1df5f4220a4cd50f (patch)
tree8a76074086d736b2918f68e1bd5997666643eaee
parentd07bb27e3196ae667a4f9f35dda17d1428c05ea8 (diff)
downloadaur-a9ddf854cbedfba62f560ddc1df5f4220a4cd50f.tar.gz
remove make dependency
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
2 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23cf692f5205..bb1d76a121ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = git-credential-1password-git
pkgdesc = Git credential.helper using 1Password for storage
- pkgver = autogenerated
+ pkgver = r35.76a354f
pkgrel = 1
url = https://github.com/develerik/git-credential-1password
arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
license = ISC
makedepends = git
- makedepends = go>=1.16
- makedepends = make
+ makedepends = go>=1.18
depends = git
depends = 1password-cli
provides = git-credential-1password
@@ -18,4 +20,3 @@ pkgbase = git-credential-1password-git
md5sums = SKIP
pkgname = git-credential-1password-git
-
diff --git a/PKGBUILD b/PKGBUILD
index bd9420bcb0c0..1b7b68bf407b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@ _orga=develerik
_gourl=github.com/$_orga/$_pkgname
pkgname="${_pkgname}-git"
-pkgver=autogenerated
+pkgver=r35.76a354f
pkgrel=1
pkgdesc="Git credential.helper using 1Password for storage"
-arch=('x86_64')
+arch=('x86_64' 'aarch64' 'armv7h' 'armv6h')
url="https://$_gourl"
license=('ISC')
-makedepends=('git' 'go>=1.16' 'make')
+makedepends=('git' 'go>=1.18')
depends=('git' '1password-cli')
provides=('git-credential-1password')
conflicts=("$_pkgname-dev-git" "$_pkgname-bin" "$_pkgname")
@@ -24,11 +24,22 @@ pkgver() {
}
build() {
+ local flags
+
+ _flags=(
+ -X=$_gourl/cmd.Version="$pkgver"
+ -s
+ -w
+ -linkmode=external
+ )
+
+ export CGO_ENABLED=0
+
cd $srcdir/$_pkgname
- VERSION=$pkgver make credential-helper
+ go build -ldflags="${_flags[*]}" -o "$_pkgname" $_gourl
}
package() {
- cd ${srcdir}/${_pkgname}/bin
+ cd ${srcdir}/${_pkgname}
install -DT -m0755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
}