summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM Hickford2023-08-06 16:15:13 +0100
committerM Hickford2023-08-06 16:15:13 +0100
commit265230befb222fd7c2d7a5261fe7501c70ccb048 (patch)
tree267aaf169e159690741b4666ce348ae6d9568f0e
downloadaur-265230befb222fd7c2d7a5261fe7501c70ccb048.tar.gz
new package git-credential-azure
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7eb26e0ceb17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = git-credential-azure
+ pkgdesc = Git credential helper that authenticates to Azure Repos (dev.azure.com)
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/hickford/git-credential-azure
+ arch = any
+ license = APACHE
+ makedepends = go
+ source = git-credential-azure-0.2.1.tar.gz::https://github.com/hickford/git-credential-azure/archive/v0.2.1.tar.gz
+ sha256sums = f3a05c73d03b0e5e58a9cd88275422a6b4b5e2ef75fd193b0f1c972e663c96a1
+
+pkgname = git-credential-azure
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60d076b6f5ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=git-credential-azure
+pkgver=0.2.1
+pkgrel=1
+pkgdesc='Git credential helper that authenticates to Azure Repos (dev.azure.com)'
+arch=('any')
+url="https://github.com/hickford/git-credential-azure"
+license=('APACHE')
+makedepends=('go')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/hickford/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('f3a05c73d03b0e5e58a9cd88275422a6b4b5e2ef75fd193b0f1c972e663c96a1')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ go test ./...
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}