summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2022-11-25 10:09:18 +0100
committerGiovanni Santini2022-11-25 10:09:18 +0100
commitb9981ccffd1272ec7d4cc5c353e2a31be426ef98 (patch)
tree022621da9f90a618607b846605b896a6b2ab2040
parent5d58044bb747de690ad05467297d39f677a17e1a (diff)
downloadaur-b9981ccffd1272ec7d4cc5c353e2a31be426ef98.tar.gz
upgpkg: git-credential-manager-core 2.0.877-1
- Version bump. - Use .NET SDK 6 for testing. - Handle binary renaming. - Other improvements to the PKGBUILD.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
-rw-r--r--git-credential-manager-core.install53
3 files changed, 58 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bd375a45efe..7a3e6426c670 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = git-credential-manager-core
pkgdesc = A secure Git credential helper built on .NET that runs on Windows, macOS, and Linux
- pkgver = 2.0.785
+ pkgver = 2.0.877
pkgrel = 1
url = https://github.com/GitCredentialManager/git-credential-manager
install = git-credential-manager-core.install
arch = i686
arch = x86_64
license = MIT
- checkdepends = dotnet-runtime-5.0
+ checkdepends = dotnet-runtime-6.0
makedepends = git
makedepends = dotnet-sdk
- makedepends = dotnet-runtime>=6
makedepends = dpkg
provides = git-credential-manager-core
conflicts = git-credential-manager-core-bin
replaces = git-credential-manager
options = !strip
- source = git-credential-manager-core::git+https://github.com/GitCredentialManager/git-credential-manager.git#tag=v2.0.785
+ source = git-credential-manager-core::git+https://github.com/GitCredentialManager/git-credential-manager.git#tag=v2.0.877
source = trim-executables.diff
sha256sums = SKIP
sha256sums = 3eb41718ef9c701307a6ca7ef85b6993d93fe55b5ad4fad632ff5722779397cf
diff --git a/PKGBUILD b/PKGBUILD
index 9b0813ef5a3d..f6fee1f8dc11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@ pkgname=(
"$pkgbase"
"${pkgbase}-extras"
)
-pkgver=2.0.785
+pkgver=2.0.877
pkgrel=1
pkgdesc="A secure Git credential helper built on .NET that runs on Windows, macOS, and Linux"
arch=(i686 x86_64)
url="https://github.com/GitCredentialManager/git-credential-manager"
license=('MIT')
-makedepends=(git dotnet-sdk 'dotnet-runtime>=6' dpkg)
-checkdepends=(dotnet-runtime-5.0)
+makedepends=(git dotnet-sdk dpkg)
+checkdepends=(dotnet-runtime-6.0)
provides=($pkgname)
conflicts=("${pkgname}-bin")
replaces=(git-credential-manager)
@@ -22,13 +22,15 @@ source=("$pkgbase::git+$url.git#tag=v$pkgver"
sha256sums=('SKIP'
'3eb41718ef9c701307a6ca7ef85b6993d93fe55b5ad4fad632ff5722779397cf')
-prepare() {
- cd "$pkgbase"
+# Seems that trimming is not required, either because of newer .NET or project changes
+# Feel free to uncomment these lines if needed
+#prepare() {
+ #cd "$pkgbase"
# Based on this chinese article:
# https://live4thee.github.io/posts/2021-02-09-dotnet-core-on-linux-2/
# Thanks web translators :P
- git apply ../trim-executables.diff
-}
+ #git apply ../trim-executables.diff
+#}
build() {
cd "$pkgbase"
@@ -49,11 +51,15 @@ package_git-credential-manager-core() {
mkdir -p "$pkgdir/usr/lib/share/$pkgname"
mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
- for bin in git-credential-manager-core
+ for bin in git-credential-manager
do
cp "out/linux/Packaging.Linux/payload/Release/$bin" "$pkgdir/usr/lib/share/$pkgname"
ln -s "/usr/lib/share/$pkgname/$bin" "$pkgdir/usr/bin/$bin"
done
+ # Deal with the different naming convention
+ # https://github.com/GitCredentialManager/git-credential-manager/pull/551
+ # https://github.com/GitCredentialManager/git-credential-manager/blob/main/docs/rename.md
+ ln -s "/usr/lib/share/$pkgname/git-credential-manager" "$pkgdir/usr/bin/$pkgname"
cp LICENSE "$pkgdir/usr/share/licenses/$pkgname"
}
diff --git a/git-credential-manager-core.install b/git-credential-manager-core.install
index 96386db597f2..5d23f24fbdaa 100644
--- a/git-credential-manager-core.install
+++ b/git-credential-manager-core.install
@@ -1,17 +1,46 @@
-## arg 1: the new package version
post_install() {
- echo "Remember to execute:"
- echo
- echo " git-credential-manager-core configure"
- echo
- echo "In order to use Git-Credential-Manager-Core."
- echo
- echo "Additionally, follow the guide here:"
- echo
- echo " https://aka.ms/gcmcore-linuxcredstores"
- echo
+ cat << EOF
+Configure Git to use Git Credential Manager via:
+
+ git-credential-manager configure
+
+Additionally, follow the guide here:
+
+https://aka.ms/gcmcore-linuxcredstores
+
+EOF
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ if [ $(vercmp "$2" 2.0.877) -lt 0 -a $(vercmp "$1" 2.0.877) -ge 0 ]
+ then
+ cat << EOF
+Since version 2.0.877, Git Credential Manager binary was changed from:
+ git-credential-manager-core
+to:
+ git-credential-manager
+
+Ensure all the paths are correct within your Git configuration via e.g.:
+
+ git config --global --edit
+
+You can also get the change via:
+ git-credential-manager configure
+EOF
+ fi
}
post_remove() {
- echo "Control your 'git config' and remove all the informations related to Git-Credential-Manager-Core"
+cat << EOF
+You should also modify your user config and remove references to
+Git Credential Manager.
+
+You can do so via e.g. :
+
+ git config --global --edit
+
+and remove the information for Git Credential Manager.
+EOF
}