summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2014-04-01 12:58:54 +0300
committerCaleb Maclennan2014-04-01 12:58:54 +0300
commite46533ce5aa1bef6bc5862657f0720e2357d402f (patch)
treea5373c96d2f78772707b0ef1e6bc5be6e3125533
downloadaur-e46533ce5aa1bef6bc5862657f0720e2357d402f.tar.gz
adopted orphan package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e820b38c35f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = git-crypt-git
+ pkgdesc = Transparent file encryption in Git
+ pkgver = 20131230
+ pkgrel = 1
+ url = http://www.agwa.name/projects/git-crypt/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc
+ makedepends = git
+ makedepends = make
+ makedepends = openssl
+ provides = git-crypt
+ conflicts = git-crypt
+ source = git+https://github.com/AGWA/git-crypt
+ sha256sums = SKIP
+
+pkgname = git-crypt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2fff440c9e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=git-crypt-git
+pkgver=20131230
+pkgrel=1
+pkgdesc="Transparent file encryption in Git"
+arch=('i686' 'x86_64')
+makedepends=('gcc' 'git' 'make' 'openssl')
+url="http://www.agwa.name/projects/git-crypt/"
+license=('GPL3')
+source=(git+https://github.com/AGWA/git-crypt)
+sha256sums=('SKIP')
+provides=('git-crypt')
+conflicts=('git-crypt')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+build() {
+ cd ${pkgname%-git}
+
+ msg 'Building...'
+ make
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg 'Installing...'
+ mkdir -p "${pkgdir}/usr/bin"
+ make PREFIX="$pkgdir/usr" install
+
+ msg 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+ find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+}